X
Tap here to go to the mobile version of the site.
An updated version of Firefox is available to address the issues with Add-ons disabled or fail to install on Firefox. You can download the update for your OS here: https://www.mozilla.org/firefox/new/ For Known Issues and Workarounds, please check out the update at https://support.mozilla.org/kb/add-ons-disabled-or-fail-to-install-firefox

Support Forum

Open excel or word document with hyperlink

Posted

Up until 66.0.1 I could open an excel or word document from the intranet home page that I created. You click on the link and a dialog box would pop up asking if you wanted to open the file or save the file. Now, when you click on the same link, it only gives you the option to save the file. I don't need to save it, it's already saved. I need to open it and work on it. How can I get 66.0.1 to function in the same way as older versions of firefox so that I can open the aforementioned office files? Thanks. Wayne

Up until 66.0.1 I could open an excel or word document from the intranet home page that I created. You click on the link and a dialog box would pop up asking if you wanted to open the file or save the file. Now, when you click on the same link, it only gives you the option to save the file. I don't need to save it, it's already saved. I need to open it and work on it. How can I get 66.0.1 to function in the same way as older versions of firefox so that I can open the aforementioned office files? Thanks. Wayne
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

jscher2000
  • Top 10 Contributor
8314 solutions 68040 answers

knirkle said

Up until 66.0.1 I could open an excel or word document from the intranet home page that I created. You click on the link and a dialog box would pop up asking if you wanted to open the file or save the file. Now, when you click on the same link, it only gives you the option to save the file.

Hi Wayne, I realize Firefox 66.0.1 was released pretty shortly after Firefox 66.0, but do you know whether this worked normally in Firefox 66.0, or last worked normally in Firefox 65?

Could you double-check your Application settings on the Preferences page:

  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

Scroll down to the Files and Applications section.

In the box listing actions for different types of downloads, do you still have "Always Ask" for Word and Excel? Try changing this setting a couple times and then back to "Always Ask" to see whether that makes any difference.

I don't need to save it, it's already saved.

Well, when you follow a link to an Office document in Firefox, you cannot edit the file in the browser; content displayed in Firefox is generally read-only unless it's a web page that provides the capability to modify the page. So Firefox will always download the file whether you use Open -- document is downloaded automatically to a temp folder -- or Save -- you control where the download is saved.

''knirkle [[#question-1254498|said]]'' <blockquote> Up until 66.0.1 I could open an excel or word document from the intranet home page that I created. You click on the link and a dialog box would pop up asking if you wanted to open the file or save the file. Now, when you click on the same link, it only gives you the option to save the file. </blockquote> Hi Wayne, I realize Firefox 66.0.1 was released pretty shortly after Firefox 66.0, but do you know whether this worked normally in Firefox 66.0, or last worked normally in Firefox 65? Could you double-check your Application settings on the Preferences page: * Mac: "3-bar" menu button (or Firefox menu) > Preferences * Windows: "3-bar" menu button (or Tools menu) > Options * Linux: "3-bar" menu button (or Edit menu) > Preferences * Any system: type or paste '''about:preferences''' into the address bar and press Enter/Return to load it Scroll down to the '''Files and Applications''' section. In the box listing actions for different types of downloads, do you still have "Always Ask" for Word and Excel? Try changing this setting a couple times and then back to "Always Ask" to see whether that makes any difference. <blockquote>I don't need to save it, it's already saved.</blockquote> Well, when you follow a link to an Office document in Firefox, you cannot edit the file in the browser; content displayed in Firefox is generally read-only unless it's a web page that provides the capability to modify the page. So Firefox will always download the file whether you use Open -- document is downloaded automatically to a temp folder -- or Save -- you control where the download is saved.
Was this helpful to you? 0
Quote

Question owner

jscher2000,

   Thank you for trying to assist me with this problem.

jscher2000 said

Hi Wayne, I realize Firefox 66.0.1 was released pretty shortly after Firefox 66.0, but do you know whether this worked normally in Firefox 66.0, or last worked normally in Firefox 65?

Not sure of the answer to this question. I don't know what version of Firefox was running prior to last weekend. When I went back to work today, it had upgraded itself to 66.0.1 and none of my links would work.

jscher2000 said

Could you double-check your Application settings on the Preferences page:
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it
Scroll down to the Files and Applications section. In the box listing actions for different types of downloads, do you still have "Always Ask" for Word and Excel? Try changing this setting a couple times and then back to "Always Ask" to see whether that makes any difference.

When I do this, there are no options for .docx or .xlsx. only the following: ircs - Always Ask irc - Always Ask webcal - Always Ask PDF - Preview In Firefox

    How do you populate this list with other extensions.  I have clicked on links to both .docx and .xlsx files, but it does not add those extensions to the application dialog box.


jscher2000 said

Well, when you follow a link to an Office document in Firefox, you cannot edit the file in the browser; content displayed in Firefox is generally read-only unless it's a web page that provides the capability to modify the page. So Firefox will always download the file whether you use Open -- document is downloaded automatically to a temp folder -- or Save -- you control where the download is saved.

Previously, it wouldn't preview the file, Firefox would open the document in it's native program so that it could be worked on and edited and saved. I have literally been doing this from the intranet page I created since the first release of Firefox many years ago.

jscher2000, Thank you for trying to assist me with this problem. ''jscher2000 [[#answer-1208862|said]]'' <blockquote> Hi Wayne, I realize Firefox 66.0.1 was released pretty shortly after Firefox 66.0, but do you know whether this worked normally in Firefox 66.0, or last worked normally in Firefox 65? </blockquote> Not sure of the answer to this question. I don't know what version of Firefox was running prior to last weekend. When I went back to work today, it had upgraded itself to 66.0.1 and none of my links would work. ''jscher2000 [[#answer-1208862|said]]'' <blockquote> Could you double-check your Application settings on the Preferences page: * Mac: "3-bar" menu button (or Firefox menu) > Preferences * Windows: "3-bar" menu button (or Tools menu) > Options * Linux: "3-bar" menu button (or Edit menu) > Preferences * Any system: type or paste '''about:preferences''' into the address bar and press Enter/Return to load it Scroll down to the '''Files and Applications''' section. In the box listing actions for different types of downloads, do you still have "Always Ask" for Word and Excel? Try changing this setting a couple times and then back to "Always Ask" to see whether that makes any difference. </blockquote> When I do this, there are no options for .docx or .xlsx. only the following: ircs - Always Ask irc - Always Ask webcal - Always Ask PDF - Preview In Firefox How do you populate this list with other extensions. I have clicked on links to both .docx and .xlsx files, but it does not add those extensions to the application dialog box. ''jscher2000 [[#answer-1208862|said]]'' <blockquote> Well, when you follow a link to an Office document in Firefox, you cannot edit the file in the browser; content displayed in Firefox is generally read-only unless it's a web page that provides the capability to modify the page. So Firefox will always download the file whether you use Open -- document is downloaded automatically to a temp folder -- or Save -- you control where the download is saved. </blockquote> Previously, it wouldn't preview the file, Firefox would open the document in it's native program so that it could be worked on and edited and saved. I have literally been doing this from the intranet page I created since the first release of Firefox many years ago.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8314 solutions 68040 answers

Hmm, it sounds as though your application list might have been reset. Still, Firefox should default to "Always Ask" for documents (in contrast to executable files).

Could you check the Content-Type header that your server is sending with the document? A way to do that is:

(1) Before clicking the link to the file, open Firefox's Network Monitor in the lower part of the tab. Either:

  • "3-bar" menu button > Web Developer > Network
  • (menu bar) Tools > Web Developer > Network
  • (Windows) Command+Alt+e

(2) Click the link and Firefox should add the request to the list in the Network tab. You can cancel the dialog.

(3) Click the request in the list and Firefox should open a panel to the right showing the Headers. If it shows a different tab, click the Headers tab.

Under "Response Headers" look for Content-Type. The official types are:

  • .doc => "application/msword"
  • .docx => "application/vnd.openxmlformats-officedocument.wordprocessingml.document"
  • .xls => "application/vnd.ms-excel"
  • .xlsx => "application/vnd.openxmlformats-officedocument.spreadsheetml.sheet"

Is the server sending those?

Hmm, it sounds as though your application list might have been reset. Still, Firefox should default to "Always Ask" for documents (in contrast to executable files). Could you check the Content-Type header that your server is sending with the document? A way to do that is: (1) Before clicking the link to the file, open Firefox's Network Monitor in the lower part of the tab. Either: * "3-bar" menu button > Web Developer > Network * (menu bar) Tools > Web Developer > Network * (Windows) Command+Alt+e (2) Click the link and Firefox should add the request to the list in the Network tab. You can cancel the dialog. (3) Click the request in the list and Firefox should open a panel to the right showing the Headers. If it shows a different tab, click the Headers tab. Under "Response Headers" look for Content-Type. The official types are: * .doc => "application/msword" * .docx => "application/vnd.openxmlformats-officedocument.wordprocessingml.document" * .xls => "application/vnd''.''ms-excel" * .xlsx => "application/vnd.openxmlformats-officedocument.spreadsheetml.sheet" Is the server sending those?
Was this helpful to you? 0
Quote

Question owner

jscher2000 said

Under "Response Headers" look for Content-Type. The official types are:
  • .doc => "application/msword"
  • .docx => "application/vnd.openxmlformats-officedocument.wordprocessingml.document"
  • .xls => "application/vnd.ms-excel"
  • .xlsx => "application/vnd.openxmlformats-officedocument.spreadsheetml.sheet"
Is the server sending those?

The server is not sending those. When you click on the link, a dialog box opens with the option to either Cancel or Save File, (which downloads the file to the download folder). The network monitor shows no requests. From that same intranet page, if I click on a link to a web-site, the request area of the network monitor populates.

''jscher2000 [[#answer-1208999|said]]'' <blockquote> Under "Response Headers" look for Content-Type. The official types are: * .doc => "application/msword" * .docx => "application/vnd.openxmlformats-officedocument.wordprocessingml.document" * .xls => "application/vnd''.''ms-excel" * .xlsx => "application/vnd.openxmlformats-officedocument.spreadsheetml.sheet" Is the server sending those? </blockquote> The server is not sending those. When you click on the link, a dialog box opens with the option to either Cancel or Save File, (which downloads the file to the download folder). The network monitor shows no requests. From that same intranet page, if I click on a link to a web-site, the request area of the network monitor populates.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8314 solutions 68040 answers

A request for a download should still be recorded as a web request. Is the link opening a new tab? If you need to track URLs across tabs, it's a little more complicated.

A request for a download should still be recorded as a web request. Is the link opening a new tab? If you need to track URLs across tabs, it's a little more complicated.
Was this helpful to you?
Quote

Question owner

jscher2000 said

A request for a download should still be recorded as a web request. Is the link opening a new tab? If you need to track URLs across tabs, it's a little more complicated.

Here is a pic of my screen. You can see where I have clicked the link and it has brought up a dialog box and you can also see at the bottom left where is shows No Requests.

''jscher2000 [[#answer-1209122|said]]'' <blockquote> A request for a download should still be recorded as a web request. Is the link opening a new tab? If you need to track URLs across tabs, it's a little more complicated. </blockquote> Here is a pic of my screen. You can see where I have clicked the link and it has brought up a dialog box and you can also see at the bottom left where is shows No Requests.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8314 solutions 68040 answers

Thanks for the screenshot. I notice the page that contains the problem link is on your computer (file:// address). Since that request is just local to your hard drive, it makes sense that there's no network request. Also, since it's a local file, there's no Content-Type header informing Firefox which application setting to use. I would still think Firefox should show Open/Save/Cancel, but it seems not to be treated as a download, so I guess not. ??

Thanks for the screenshot. I notice the page that contains the problem link is on your computer (file:// address). Since that request is just local to your hard drive, it makes sense that there's no network request. Also, since it's a local file, there's no Content-Type header informing Firefox which application setting to use. I would still think Firefox should show Open/Save/Cancel, but it seems not to be treated as a download, so I guess not. ??
Was this helpful to you?
Quote
cvhorie 0 solutions 16 answers

In the options>files>applications list, there is no way to add .docx, doc, or Word to the applications. And Firefox does not do it automatically - after all Word has not been around very long.

I download from a webserver many pdf and docx files each day in exactly the same way. The file is first saved to the Download folder then a dialog comes up asking if I want to open it (and gives the correct application), even though the box to always open automatically is ticked.

So there are two things going wrong with this process of dealing with files needing applications to process. The first is that it seems impossible for Firefox to acknowledge Microsoft. The second is that Firefox does not follow the options the user has set.

In the options>files>applications list, there is no way to add .docx, doc, or Word to the applications. And Firefox does not do it automatically - after all Word has not been around very long. I download from a webserver many pdf and docx files each day in exactly the same way. The file is first saved to the Download folder then a dialog comes up asking if I want to open it (and gives the correct application), even though the box to always open automatically is ticked. So there are two things going wrong with this process of dealing with files needing applications to process. The first is that it seems impossible for Firefox to acknowledge Microsoft. The second is that Firefox does not follow the options the user has set.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8314 solutions 68040 answers

Hi cvhorie, the DOCX format is only about, what, 12 years old? Still, there are some servers that do not send the correct Content-Type header with a DOCX file, which Firefox requires to handle it automatically. I have an example document that should work. Do you want to give it a try:

First load: https://www.jeffersonscher.com/temp/Blank.docx?1 => if you get the Open/Save/Cancel dialog, set your preference

Second load: https://www.jeffersonscher.com/temp/Blank.docx?2 => test whether Firefox follows instructions

(The reason for the ?1 and ?2 is to create a unique URL so Firefox doesn't retrieve the document from cache on the second load.)

Does that one work?

If you need to download frequently from a server that does not send the correct Content-Type, there is a workaround. I created an extension which corrects common content types and allows you to add custom ones:

https://addons.mozilla.org/firefox/addon/content-type-fixer/

By default, the extension is inactive (toolbar button has Zzzz). To turn it on, click the button. Because it adds some tiny amount of overhead to your browsing, when you are done with the problem site, you can turn it off by clicking the button again and choosing Stop from the menu.

Any improvement?

Hi cvhorie, the DOCX format is only about, what, 12 years old? Still, there are some servers that do not send the correct Content-Type header with a DOCX file, which Firefox requires to handle it automatically. I have an example document that ''should'' work. Do you want to give it a try: First load: https://www.jeffersonscher.com/temp/Blank.docx?1 => if you get the Open/Save/Cancel dialog, set your preference Second load: https://www.jeffersonscher.com/temp/Blank.docx?2 => test whether Firefox follows instructions (The reason for the ?1 and ?2 is to create a unique URL so Firefox doesn't retrieve the document from cache on the second load.) Does that one work? If you need to download frequently from a server that does not send the correct Content-Type, there is a workaround. I created an extension which corrects common content types and allows you to add custom ones: https://addons.mozilla.org/firefox/addon/content-type-fixer/ By default, the extension is inactive (toolbar button has Zzzz). To turn it on, click the button. Because it adds some tiny amount of overhead to your browsing, when you are done with the problem site, you can turn it off by clicking the button again and choosing Stop from the menu. Any improvement?
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.