Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Still unable to eliminate login when moving .default from Windows to Mint.

  • 17 replies
  • 1 has this problem
  • 45 views
  • Last reply by Toad-Hall

more options

Well, I deleted and started the process of reloading loading TB. I deleted pkcs11.txt from my Windows default directory. I went to /home/me/.thunderbird and renamed the 'new .default' created by the reload. After this I copied the Windows default directory and renamed it 'new.default'. I now have my entire Windows TB folder structure. The first time launching TB and requesting my emails, it asks for the pop password. If I leave the option for saving the password unchecked, it doesn't ask for passwords again until I restart TB. Same procedure when I try to send the first email. Better than a pop login after each email request but still an issue.

Still looking for a fix...thanks

All Replies (17)

more options

Make sure Thunderbird is not running. In the profile folder delete the key3.db and key4.db files as well the logins.json. Or rename them Restart Thunderbird.

This will delete ALL saved passwords. it will also allow the files to be recreated in Linux where they will probably be stable

more options

Deleting key3 and key4.db as well as logins.json did not change the requirement for the logins on start-up. Linux has not re-created those files in .thunderbird.

more options

does your linux system come with some sort of password manager of it's own?

more options

I'm running the latest version of mint. No password manager as far as I know.

more options
If I leave the option for saving the password unchecked

Why don't you simply check the option, so that Thunderbird remembers the password? It's the server demanding authentication, not Thunderbird. There's no way around this.

more options

If I enter the password and check the box, Tb stops periodic checking for any incoming emails and if I check for TB saved passwords, there are none. If I force an email check by clicking 'get messages' the password request appears again.

more options
If I force an email check by clicking 'get messages' the password request appears again.

So that means Thunderbird doesn't even get to the point to submit your password to the server. See https://support.mozilla.org/kb/cannot-receive-messages for troubleshooting.

more options

I use POP mail with Gmail.

I may not have been clear about the symptoms. When I launch TB, a box with the header "enter your password" appears. There is a slot to enter the password and below the slot there is a check box "use password manager to remember the password" At that point, if I enter the password and check the box to save it, my emails are downloaded from gmail. However, the next time I request a manual email check the box appears again requesting my password. This will happen each time I request mail manually unless I don't check the "use password manager to remember the password" box. Then I'm good till I relaunch TB and the cycle repeats. When I check preferences/security/saved passwords, the form is blank with no password saved in any case.

If I choose to compose and send an email after initially launching TB, I run into the same issue with the 'enter password' box. with the following difference. If I enter my password and check the remember pw box, I get a message box:

SEND MESSAGE ERROR Sending of message failed. An error occurred while sending mail. Could not get password for smtp.gmail.com. The message was not sent.

If, however, while sending mail, I enter my password but do not check the save pw box, I will be fine till the next session of TB.

more options
I use POP mail with Gmail.

You'll need to 'Allow less secure apps' in your Google settings. https://support.google.com/accounts/answer/6009563

more options

Thanks for that...I have always had less secure apps on.

more options

Can you try with a new profile? Create a new profile using profile manager, and then start Thunderbird with the new profile. https://support.mozilla.org/kb/using-multiple-profiles

Set up your existing email account in the new profile. When prompted, check the box to remember the password.

Do you still get the password prompt when sending mail, and when manually checking for new mail?

more options

Hi, this entire exercise was to transfer Windows TB profile to Mint. I'm a little nervous about creating another profile and accidentally blowing away the Windows profile which works fine and transferred cleanly.

more options
I'm a little nervous about creating another profile and accidentally blowing away the Windows profile

This is what backups are for. https://support.mozilla.org/kb/profiles-where-thunderbird-stores-user-data#w_backing-up-a-profile

more options

"Set up your existing email account in the new profile. When prompted, check the box to remember the password."

I had actually done this originally when I set up TB in Mint. During that time it actually came up with a different screen that requested my used name and password at the pop server.

"Do you still get the password prompt when sending mail, and when manually checking for new mail?"

It did indeed not get a password request after I started running the new TB profile, but when I overwrote the new profile with the old Windows profile, I ran into the present issue of pw request for first download of the day and first outgoing email.

more options
It did indeed not get a password request after I started running the new TB profile, but when I overwrote the new profile with the old Windows profile, I ran into the present issue

I'm not sure I'm getting this right. Are you saying that creating a new profile fixed the problem? And then you copied the troubled profile over the newly created one anyway? If so, what exactly are you trying to achieve with this?

more options

Creating the new profiile indeed worked fine and I was not asked for pop passwords when running TB but I have an approximately 12 year email history profile from my Windows pc I wanted to transfer to Mint.

more options

re :Creating the new profiile indeed worked fine and I was not asked for pop passwords when running TB This was the correct thing to do as something in the old profile was not behaving correctly.

re : but when I overwrote the new profile with the old Windows profile, I ran into the present issue

But you knew that was going happen because you had already confirmed the old windows profile was not working correctly. So it does seem odd that you did this.


After creating a new profile and adding pop mail account you needed to exit Thunderbird and access the new profile folder. click on 'Mail' folder to see pop mail account name folder. click on pop mail account folder to see contents. This is where you need to put a copy of all the mbox files from the old profile.


mbox files (no extension) contain emails. See example image below. These are located in the pop mail account in the old not functioning profile. This is what you want to see in the new profile. You need to copy all those mbox files from the old pop mail account in bad profile into the new pop mail account in new profile. If the old pop mail account has *.sbd folders, then copy them as well as these contain subfolders which may also have emails in mbox files.

Then start Thunderbird.