X
Tap here to go to the mobile version of the site.

Support Forum

Is there a way to stop alert dialog from showing up without completely disabling JavaScript through about:config?

Posted

Hi there My question is

=

Is there a way to stop alert dialog from showing up without completely disabling JavaScript through about:config?

We think alert boxes are pure JavaScript and not considered pop-up.

Thank you!

Hi there My question is === Is there a way to stop alert dialog from showing up without completely disabling JavaScript through about:config? We think alert boxes are pure JavaScript and not considered pop-up. Thank you!
Attached screenshots
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Android 5.1.1; Tablet; rv:58.0) Gecko/58.0 Firefox/58.0

More Information

FredMcD
  • Top 10 Contributor
4221 solutions 58912 answers
See if this helps: https://support.mozilla.org/en-US/kb/push-notifications-firefox
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8633 solutions 70605 answers

Helpful Reply

There isn't a built-in preference to block the window.alert() function. I think it can be suppressed by injecting a script into a page that replace it with a "no-op" (do nothing) function, but I haven't searched for an extension or user script for that.

There isn't a built-in preference to block the window.alert() function. I think it can be suppressed by injecting a script into a page that replace it with a "no-op" (do nothing) function, but I haven't searched for an extension or user script for that.
Was this helpful to you? 1
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17411 solutions 157274 answers

Maybe you do not get this alert if you block access to the location in "Tools -> Page Info -> Permissions".

Maybe you do not get this alert if you block access to the location in "Tools -> Page Info -> Permissions".
Was this helpful to you?
Quote

Question owner

cor-el said

Maybe you do not get this alert if you block access to the location in "Tools -> Page Info -> Permissions".

Yeah .. we already blocked most stuff under Firefox options Still No good..

''cor-el [[#answer-1207653|said]]'' <blockquote> Maybe you do not get this alert if you block access to the location in "Tools -> Page Info -> Permissions". </blockquote> Yeah .. we already blocked most stuff under Firefox options Still No good..
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
520 solutions 4880 answers

sh2dc said

we already blocked most stuff under Firefox options
Still No good..

Just to make sure ...... Does this mean that you went to Privacy & Security => Permissions => Location, then clicked on 'Settings', found www.bing.com listed there, checked the box saying : 'Block new requests asking to access your location', clicked 'Save Changes' and then closed and restarted Firefox  ?

In addition you could go to Page Info, as suggested by cor-el, and under the Permissions tab scroll down to 'Access Your Location', uncheck 'Use Default' and check 'Block' (worth a try .....).

''sh2dc [[#answer-1207747|said]]'' <blockquote> we already blocked most stuff under Firefox options<BR> Still No good.. </blockquote> Just to make sure ...... Does this mean that you went to Privacy & Security => Permissions => Location, then clicked on 'Settings', found www.bing.com listed there, checked the box saying : 'Block new requests asking to access your location', clicked 'Save Changes' and then closed and restarted Firefox ? In addition you could go to Page Info, as suggested by cor-el, and under the Permissions tab scroll down to 'Access Your Location', uncheck 'Use Default' and check 'Block' (worth a try .....).
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.