X
Tap here to go to the mobile version of the site.

Support Forum

My website works slow on Mozilla

Posted

Hello,

Mozilla is faster than google chrome and whenever i use to browse website mozilla works faster. However i have a website https://bloggerwalk.com which works slows on mozilla as compared to google chrome. Is this a browser issue or my website issue.

Thanks and Regards

Hello, Mozilla is faster than google chrome and whenever i use to browse website mozilla works faster. However i have a website https://bloggerwalk.com which works slows on mozilla as compared to google chrome. Is this a browser issue or my website issue. Thanks and Regards

Chosen solution

The website was very fast on my Firefox.

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

FredMcD
  • Top 10 Contributor
4026 solutions 56280 answers

Chosen Solution

The website was very fast on my Firefox.

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

The website was very fast on my Firefox. Many site issues can be caused by corrupt cookies or cache. '''Warning ! ! ''' This will log you out of sites you're logged in to. You may also lose any settings for that website. * [https://support.mozilla.org/en-US/kb/delete-cookies-remove-info-websites-stored Delete cookies to remove the information websites have stored on your computer] {web link} * [https://support.mozilla.org/en-US/kb/how-clear-firefox-cache How to clear the Firefox cache] {web link} If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Did this help? While you are in safe mode; Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches. ''[https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration How to disable Hardware Acceleration]'' {web link}
Was this helpful to you? 1
Quote

Question owner

Great, it solved my issue. Thanks a lot

''Great, it solved my issue. Thanks a lot''
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4026 solutions 56280 answers

Glad to help. Safe Surfing.

Was it clearing the data, or Safe Mode? If Safe Mode, that means something in Firefox is the issue.

Glad to help. Safe Surfing. Was it clearing the data, or Safe Mode? If Safe Mode, that means something in Firefox is the issue.
Was this helpful to you?
Quote

Question owner

i cleared cookies and it started working fine

Thanks

i cleared cookies and it started working fine Thanks
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.