X
Tap here to go to the mobile version of the site.

Support Forum

Don't autoplay videos does no longer work in Firefox 66.0

Posted

Since the update to Firefox 66 my settings to disable autoplay videos seems to be broken. I would prefer certain news sites to not start one (ore sometimes more!) streams whenever a page is loaded. For example, aftonbladet.se or expressen.se do this all the time.

Is there a work around or a new setting since the setting media.autoplay.default set to 2 does not appear to work anymore.

Since the update to Firefox 66 my settings to disable autoplay videos seems to be broken. I would prefer certain news sites to not start one (ore sometimes more!) streams whenever a page is loaded. For example, aftonbladet.se or expressen.se do this all the time. Is there a work around or a new setting since the setting media.autoplay.default set to 2 does not appear to work anymore.

Chosen solution

To make the "stop autoplay" work again use these settings:

media.autoplay.default: 1 media.autoplay.enabled.user-gestures-needed: false media.autoplay.allow-muted: false

Although the "media.autoplay.enabled.user-gestures-needed" seems to be wrong it brings back the "stop autoplay" feature.

Read this answer in context 3
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

aalppr 1 solutions 8 answers

Hi! Have you tried reinstalling firefox?

Hi! Have you tried reinstalling firefox?
Was this helpful to you? 0
Quote

Question owner

No, reinstalling is not the first option due to all settings and plugins. But I'll do it if nothing else works...

No, reinstalling is not the first option due to all settings and plugins. But I'll do it if nothing else works...
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17216 solutions 155528 answers

Try this extension.

Try this extension. *Disable HTML5 Autoplay https://addons.mozilla.org/firefox/addon/disable-autoplay/
Was this helpful to you? 0
Quote

Question owner

Thank you cor-el for the suggestion.

But sorry, this didn’t help. The videos are still auto-starting.

Thank you cor-el for the suggestion. But sorry, this didn’t help. The videos are still auto-starting.
Was this helpful to you?
Quote
WestEnd
  • Top 10 Contributor
60 solutions 5243 answers

First link the videos don't play and second one the small videos seems to play and then stop as though doing a preview. So how do you mean Auto-starting?

First link the videos don't play and second one the small videos seems to play and then stop as though doing a preview. So how do you mean Auto-starting?
Was this helpful to you? 0
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17216 solutions 155528 answers

Do you have other extensions installed that might be causing blocking autoplay not working?

Do you have other extensions installed that might be causing blocking autoplay not working? *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems
Was this helpful to you?
Quote

Question owner

I decided to post my message in case this was a common problem or a bug. By now there should have been more users having the same problem if that were the case. (And there are in fact some postings which describe problems resembling my issue)

The issue started with the update to FF 66.0. But this may nevertheless be a problem in my local system. As soon as I get the time, I will save all my settings in my plugins and do what @aalppr asked and make a fresh install. If the problem remains, I will test if there are any conflicts in my loaded plugins (as indicated by @cor-el).

Thanks for all help so far!

I will let the problem be unresolved until I know more.

I decided to post my message in case this was a common problem or a bug. By now there should have been more users having the same problem if that were the case. (And there are in fact some postings which describe problems resembling my issue) The issue started with the update to FF 66.0. But this may nevertheless be a problem in my local system. As soon as I get the time, I will save all my settings in my plugins and do what @aalppr asked and make a fresh install. If the problem remains, I will test if there are any conflicts in my loaded plugins (as indicated by @cor-el). Thanks for all help so far! I will let the problem be unresolved until I know more.

Modified by Priskvark

Was this helpful to you? 0
Quote

Question owner

I made a fresh install of FF 66.0 without any active plugins. The problem remains and Firefox starts playing videos whenever a site enables it to play. Maybe this is a problem in my environment and that not all users are affected.

I have decided to downgrade to FF 55.0.2 until I am positive that the ability to stop videos from autoplaying is restored.

I made a fresh install of FF 66.0 without any active plugins. The problem remains and Firefox starts playing videos whenever a site enables it to play. Maybe this is a problem in my environment and that not all users are affected. I have decided to downgrade to FF 55.0.2 until I am positive that the ability to stop videos from autoplaying is restored.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17216 solutions 155528 answers

You can modify these prefs on the about:config page to see if that works for you..

  • media.autoplay.default = 1 [0=Allowed, 1=Blocked, 2=Prompt]
  • media.autoplay.enabled.user-gestures-needed = true
  • media.autoplay.allow-muted = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

You can modify these prefs on the about:config page to see if that works for you.. *media.autoplay.default = 1 [0=Allowed, 1=Blocked, 2=Prompt] *media.autoplay.enabled.user-gestures-needed = true *media.autoplay.allow-muted = false You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *http://kb.mozillazine.org/about:config
Was this helpful to you?
Quote
koooper 4 solutions 8 answers

Chosen Solution

To make the "stop autoplay" work again use these settings:

media.autoplay.default: 1 media.autoplay.enabled.user-gestures-needed: false media.autoplay.allow-muted: false

Although the "media.autoplay.enabled.user-gestures-needed" seems to be wrong it brings back the "stop autoplay" feature.

To make the "stop autoplay" work again use these settings: media.autoplay.default: '''1''' media.autoplay.enabled.user-gestures-needed: '''false''' media.autoplay.allow-muted: '''false''' Although the "media.autoplay.enabled.user-gestures-needed" seems to be wrong it brings back the "stop autoplay" feature.
Was this helpful to you? 3
Quote

Question owner

Thank you koooper for the solution! Now I am running FF 66.0.1 and I got rid of the annoying flickering videos.

(Thanks also to all the other helpful users posting tips and suggestions.)

Thank you koooper for the solution! Now I am running FF 66.0.1 and I got rid of the annoying flickering videos. (Thanks also to all the other helpful users posting tips and suggestions.)
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.