X
Tap here to go to the mobile version of the site.

Support Forum

Has Firefox become Chrome?

Posted

Recent updates have made Firefox eat up all the memory. It opens up multiple processes in the background, just the same way, Chrome did and affected people moved to the Firefox.

I have opened one Window opened with couple of pined sites which took almost 3.0 GB of memory (4 application threads and 3 background processes). Has the Firefox been Compromised by big giants?

Plus, when you search for something even inside the Incognito mode, you'll start getting ads on same search just the moments after. Can anyone please confirm, if the Firefox is still non-profit and safe to use?

Recent updates have made Firefox eat up all the memory. It opens up multiple processes in the background, just the same way, Chrome did and affected people moved to the Firefox. I have opened one Window opened with couple of pined sites which took almost 3.0 GB of memory (4 application threads and 3 background processes). Has the Firefox been Compromised by big giants? Plus, when you search for something even inside the Incognito mode, you'll start getting ads on same search just the moments after. Can anyone please confirm, if the Firefox is still non-profit and safe to use?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 31.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

More Information

WestEnd 60 solutions 5387 answers

Did you check that the browser is opening in PB mode before exiting it and reopening it.

Did you check that the browser is opening in PB mode before exiting it and reopening it.
FredMcD
  • Top 10 Contributor
4272 solutions 59923 answers

More than one process is normal for the current Firefox. http://www.ghacks.net/2016/07/22/multi-process-firefox/

Multi-process Firefox is codenamed "e10s". https://wiki.mozilla.org/Firefox/multiprocess


Try to disable multi-process tabs in Firefox. You can disable multi-process tabs in Firefox by setting the related prefs to false on the about:config page.

browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false

Type about:config<enter> in the address bar. If a warning screen comes up, press the I Accept the Risk button. At the top of the screen is a search bar.

More than one process is normal for the current Firefox. http://www.ghacks.net/2016/07/22/multi-process-firefox/ Multi-process Firefox is codenamed "e10s". https://wiki.mozilla.org/Firefox/multiprocess Try to disable multi-process tabs in Firefox. You can disable multi-process tabs in Firefox by setting the related prefs to false on the '''about:config''' page. '''browser.tabs.remote.autostart''' = false '''browser.tabs.remote.autostart.2''' = false Type '''about:config'''<enter> in the address bar. If a warning screen comes up, press the '''I Accept the Risk''' button. At the top of the screen is a search bar.