X
Tap here to go to the mobile version of the site.

Support Forum

FF saves all my passwords and logons via master password except for one web site

Posted

FF saves all my passwords and logons via master password except for one web site, even after a restart in safe mode and refresh. No matter what I do, FF does not show the prompt for typing in the master password when I access this site. This started after I once cleared all cookies and data. I checked the list of exceptions for the affect site, www.pond5.com, but it is not listed. I have spoken the the webmaster at pond5, and they claim not to have any non-standard code that would prohibit the prompting of any master password. They suggested I use a different password saving system, but the FF system has served me well, no need to change it. I have restarted in safe mode, tried a refresh of the browser, but this one web site stubbornly refuses to be listed in my master password list. Plug-ins installed: OpnH264 video codec, Widevine Content Decryption Module, Shockwave Flash.

FF saves all my passwords and logons via master password except for one web site, even after a restart in safe mode and refresh. No matter what I do, FF does not show the prompt for typing in the master password when I access this site. This started after I once cleared all cookies and data. I checked the list of exceptions for the affect site, www.pond5.com, but it is not listed. I have spoken the the webmaster at pond5, and they claim not to have any non-standard code that would prohibit the prompting of any master password. They suggested I use a different password saving system, but the FF system has served me well, no need to change it. I have restarted in safe mode, tried a refresh of the browser, but this one web site stubbornly refuses to be listed in my master password list. Plug-ins installed: OpnH264 video codec, Widevine Content Decryption Module, Shockwave Flash.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • Firefox 65.0.1
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:65.0) Gecko/20100101 Firefox/65.0
  • Support URL: https://support.mozilla.org/1/firefox/65.0.1/Darwin/en-US/

Extensions

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x67df
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x1002
  • contentUsesTiling: True
  • crashGuards: []
  • driverDate:
  • driverVersion:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'OpenGL Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'OPENGL_COMPOSITING'}, {u'status': u'opt-in', u'description': u'WebRender', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}], u'name': u'WEBRENDER'}, {u'status': u'blocked', u'description': u'WebRender qualified', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blocked', u'message': u'No qualified hardware', u'type': u'env'}], u'name': u'WEBRENDER_QUALIFIED'}, {u'status': u'available', u'description': u'Off Main Thread Painting', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'OMTP'}]}
  • info: {u'TileHeight': 1024, u'ApzWheelInput': 1, u'ApzDragInput': 1, u'ApzKeyboardInput': 1, u'ApzAutoscrollInput': 1, u'AzureFallbackCanvasBackend': u'none', u'TileWidth': 1024, u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • offMainThreadPaintEnabled: True
  • offMainThreadPaintWorkerCount: 3
  • usesTiling: True
  • webgl1DriverExtensions: GL_ARB_blend_func_extended GL_ARB_draw_buffers_blend GL_ARB_draw_indirect GL_ARB_ES2_compatibility GL_ARB_explicit_attrib_location GL_ARB_gpu_shader_fp64 GL_ARB_gpu_shader5 GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_occlusion_query2 GL_ARB_sample_shading GL_ARB_sampler_objects GL_ARB_separate_shader_objects GL_ARB_shader_bit_encoding GL_ARB_shader_subroutine GL_ARB_shading_language_include GL_ARB_tessellation_shader GL_ARB_texture_buffer_object_rgb32 GL_ARB_texture_cube_map_array GL_ARB_texture_gather GL_ARB_texture_query_lod GL_ARB_texture_rgb10_a2ui GL_ARB_texture_storage GL_ARB_texture_swizzle GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback3 GL_ARB_vertex_attrib_64bit GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_viewport_array GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_depth_bounds_test GL_EXT_texture_compression_s3tc GL_EXT_texture_filter_anisotropic GL_EXT_texture_mirror_clamp GL_EXT_texture_sRGB_decode GL_APPLE_client_storage GL_APPLE_container_object_shareable GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_texture_range GL_ATI_texture_mirror_once GL_NV_texture_barrier
  • webgl1Extensions: ANGLE_instanced_arrays EXT_blend_minmax EXT_color_buffer_half_float EXT_texture_compression_rgtc EXT_frag_depth EXT_sRGB EXT_shader_texture_lod EXT_texture_filter_anisotropic EXT_disjoint_timer_query OES_element_index_uint OES_standard_derivatives OES_texture_float OES_texture_float_linear OES_texture_half_float OES_texture_half_float_linear OES_vertex_array_object WEBGL_color_buffer_float WEBGL_compressed_texture_s3tc WEBGL_compressed_texture_s3tc_srgb WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_depth_texture WEBGL_draw_buffers WEBGL_lose_context
  • webgl1Renderer: ATI Technologies Inc. -- AMD Radeon Pro 570 OpenGL Engine
  • webgl1Version: 4.1 ATI-1.68.21
  • webgl1WSIInfo: CGL
  • webgl2DriverExtensions: GL_ARB_blend_func_extended GL_ARB_draw_buffers_blend GL_ARB_draw_indirect GL_ARB_ES2_compatibility GL_ARB_explicit_attrib_location GL_ARB_gpu_shader_fp64 GL_ARB_gpu_shader5 GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_occlusion_query2 GL_ARB_sample_shading GL_ARB_sampler_objects GL_ARB_separate_shader_objects GL_ARB_shader_bit_encoding GL_ARB_shader_subroutine GL_ARB_shading_language_include GL_ARB_tessellation_shader GL_ARB_texture_buffer_object_rgb32 GL_ARB_texture_cube_map_array GL_ARB_texture_gather GL_ARB_texture_query_lod GL_ARB_texture_rgb10_a2ui GL_ARB_texture_storage GL_ARB_texture_swizzle GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback3 GL_ARB_vertex_attrib_64bit GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_viewport_array GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_depth_bounds_test GL_EXT_texture_compression_s3tc GL_EXT_texture_filter_anisotropic GL_EXT_texture_mirror_clamp GL_EXT_texture_sRGB_decode GL_APPLE_client_storage GL_APPLE_container_object_shareable GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_texture_range GL_ATI_texture_mirror_once GL_NV_texture_barrier
  • webgl2Extensions: EXT_color_buffer_float EXT_texture_compression_rgtc EXT_texture_filter_anisotropic EXT_disjoint_timer_query OES_texture_float_linear WEBGL_compressed_texture_s3tc WEBGL_compressed_texture_s3tc_srgb WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_lose_context
  • webgl2Renderer: ATI Technologies Inc. -- AMD Radeon Pro 570 OpenGL Engine
  • webgl2Version: 4.1 ATI-1.68.21
  • webgl2WSIInfo: CGL
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL
  • windowUsingAdvancedLayers: False

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4245 solutions 59390 answers

Warning: There are some web pages that do not allow browsers to record or fill in the log-in information.

But if you go to the Mozilla Add-ons Web Page {web Link} (There’s a lot of good stuff here) you can try a Form Filling add-on. I found that the form-filler add-on I use is not affected.

'''Warning: ''' There are some web pages that do not allow browsers to record or fill in the log-in information. But if you go to the [https://addons.mozilla.org/en-US/firefox/ Mozilla Add-ons Web Page] {web Link} (There’s a lot of good stuff here) you can try a '''Form Filling''' add-on. I found that the form-filler add-on I use is not affected.

Question owner

Thanks Fred, but to be clear - this particular web site in the past DID allow autofill. It only stopped doing so when I cleared my cache and cookies, as part of a house-cleaning. I have also spoken to the administrators of that site, and they claim nothing has changed. So the problem must be my side.

Thanks Fred, but to be clear - this particular web site in the past DID allow autofill. It only stopped doing so when I cleared my cache and cookies, as part of a house-cleaning. I have also spoken to the administrators of that site, and they claim nothing has changed. So the problem must be my side.
FredMcD
  • Top 10 Contributor
4245 solutions 59390 answers

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

Many site issues can be caused by corrupt cookies or cache. '''Warning ! ! ''' This will log you out of sites you're logged in to. You may also lose any settings for that website. * [https://support.mozilla.org/en-US/kb/delete-cookies-remove-info-websites-stored Delete cookies to remove the information websites have stored on your computer] {web link} * [https://support.mozilla.org/en-US/kb/how-clear-firefox-cache How to clear the Firefox cache] {web link} If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Did this help? While you are in safe mode; Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches. ''[https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration How to disable Hardware Acceleration]'' {web link}

Question owner

The problem STARTED when I cleared my cache and cookies. Deleting cookies again made no difference. I have tried Safe Mode before. Made no difference. I tried the same website in Safari, and it auto-fills the logon details. The problem is something suppressing the master password dialogue in FF.

The problem STARTED when I cleared my cache and cookies. Deleting cookies again made no difference. I have tried Safe Mode before. Made no difference. I tried the same website in Safari, and it auto-fills the logon details. The problem is something suppressing the master password dialogue in FF.
FredMcD
  • Top 10 Contributor
4245 solutions 59390 answers

Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

Start your '''Computer''' in safe mode with network support. Then start Firefox. Try '''Secure''' websites. Is the problem still there? http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia
cor-el
  • Top 10 Contributor
  • Moderator
17468 solutions 157859 answers

If I check the page code then I see that the form is submitted via JavaScript AJAX. I've seen similar cases where Firefox didn't offer to save the password where also AJAX was used. The form doesn't have an ID and also no submit URL, so it is not possible to submit the form manually to see if that triggers the Firefox Password Manager.

If I check the page code then I see that the form is submitted via JavaScript AJAX. I've seen similar cases where Firefox didn't offer to save the password where also AJAX was used. The form doesn't have an ID and also no submit URL, so it is not possible to submit the form manually to see if that triggers the Firefox Password Manager.
FredMcD
  • Top 10 Contributor
4245 solutions 59390 answers

FredMcD said

I found that the form-filler add-on I use is not affected.
''FredMcD [[#answer-1203692|said]]'' <blockquote> I found that the form-filler add-on I use is not affected. </blockquote>
cor-el
  • Top 10 Contributor
  • Moderator
17468 solutions 157859 answers

Firefox only shows the master password prompt when it needs to access the Password Manager. Once you enter the MP then you are logged in to the software security device and you no longer get a MP prompt. If you cancel a MP prompt then you are logged out and need to re-enter the MP.

You can view the current status via this page (either Log In button or Log Out button is enabled).

  • Options/Preferences -> Privacy & Security
    Certificates -> Security Devices
    Select: Software Security Device
Firefox only shows the master password prompt when it needs to access the Password Manager. Once you enter the MP then you are logged in to the software security device and you no longer get a MP prompt. If you cancel a MP prompt then you are logged out and need to re-enter the MP. You can view the current status via this page (either Log In button or Log Out button is enabled). *Options/Preferences -> Privacy & Security<br>Certificates -> Security Devices<br>Select: Software Security Device

Modified by cor-el

Question owner

Yup, that looks like it did the trick, cor-el! So far so good. Thanks - I would never have found that on my own!

Yup, that looks like it did the trick, cor-el! So far so good. Thanks - I would never have found that on my own!

Question owner

OK, left it overnight to check - back to square one, FF won't trigger the MP prompt.

OK, left it overnight to check - back to square one, FF won't trigger the MP prompt.
cor-el
  • Top 10 Contributor
  • Moderator
17468 solutions 157859 answers

You can always manually login to the Password Manager by filling the prompt in the MP dialog that opens if you access the passwords.

  • Options/Preferences -> Privacy & Security: Forms & Passwords: "Saved Logins" -> "Show Passwords"
You can always manually login to the Password Manager by filling the prompt in the MP dialog that opens if you access the passwords. *Options/Preferences -> Privacy & Security: Forms & Passwords: "Saved Logins" -> "Show Passwords"

Question owner

Not sure what you intend with that, cor-el. I know how to access the list, and have done so many times to check if the website in question is listed there. It is not listed. Nor do I get an opportunity to add that particular website because FF does not trigger the MP prompt to allow me to do so.

Not sure what you intend with that, cor-el. I know how to access the list, and have done so many times to check if the website in question is listed there. It is not listed. Nor do I get an opportunity to add that particular website because FF does not trigger the MP prompt to allow me to do so.