X
Tap here to go to the mobile version of the site.

Support Forum

Other Bookmarks Open All in Tabs only sometimes shows

Posted

I am viewing my other bookmarks via Toolbar -> Bookmarks Menu Icon (Star with line underneath) -> Other Bookmarks (4th item down).

For normal bookmaks folders, when viewed this way they contain an option at the bottom of the folder to "Open All in Tabs". I notice that sometimes my "Other Bookmarks" folder also has this option - but only rarely, mnost of the time it is not there. I am not sure what is causing it to show or not show, but I would like it to always show.

- No Add-Ins installed related to bookmarks. - Bookmarks are synced between 2 computers using a Firefox account.

I am viewing my other bookmarks via Toolbar -> Bookmarks Menu Icon (Star with line underneath) -> Other Bookmarks (4th item down). For normal bookmaks folders, when viewed this way they contain an option at the bottom of the folder to "Open All in Tabs". I notice that sometimes my "Other Bookmarks" folder also has this option - but only rarely, mnost of the time it is not there. I am not sure what is causing it to show or not show, but I would like it to always show. - No Add-Ins installed related to bookmarks. - Bookmarks are synced between 2 computers using a Firefox account.
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

More Information

jscher2000
  • Top 10 Contributor
8571 solutions 70091 answers

I don't see "Open All in Tabs" at the end of either the "Bookmarks Toolbar" or "Other Bookmarks" fly-out lists on the bookmarks menu. It might be how those two work, being special top-level containers and not ordinary folders. But I don't remember if they used to work differently.

One workaround is: right-click the folder name (for example, right-click Other Bookmarks) and click Open All in Tabs from the context menu.

I don't see "Open All in Tabs" at the end of either the "Bookmarks Toolbar" or "Other Bookmarks" fly-out lists on the bookmarks menu. It might be how those two work, being special top-level containers and not ordinary folders. But I don't remember if they used to work differently. One workaround is: right-click the folder name (for example, right-click Other Bookmarks) and click Open All in Tabs from the context menu.
Was this helpful to you?
Quote

Question owner

jscher2000 said

I don't see "Open All in Tabs" at the end of either the "Bookmarks Toolbar" or "Other Bookmarks" fly-out lists on the bookmarks menu. It might be how those two work, being special top-level containers and not ordinary folders. But I don't remember if they used to work differently. One workaround is: right-click the folder name (for example, right-click Other Bookmarks) and click Open All in Tabs from the context menu.

If you right click the folder name and select Open All in Tabs, it actually opens all of the items in the root level of your bookmarks and not in the folder itself. The only workaround I have found is to open the Show All Bookmarks folder, and right click on the Other Bookmarks folder in here and select Open All in Tabs.

I have definitely seen the option there. Over the past week while I have been trying to resolve the issue it has appeared twice. I suspect it has something to do with the sync as I have no other ideas.

''jscher2000 [[#answer-1203567|said]]'' <blockquote> I don't see "Open All in Tabs" at the end of either the "Bookmarks Toolbar" or "Other Bookmarks" fly-out lists on the bookmarks menu. It might be how those two work, being special top-level containers and not ordinary folders. But I don't remember if they used to work differently. One workaround is: right-click the folder name (for example, right-click Other Bookmarks) and click Open All in Tabs from the context menu. </blockquote> If you right click the folder name and select Open All in Tabs, it actually opens all of the items in the root level of your bookmarks and not in the folder itself. The only workaround I have found is to open the Show All Bookmarks folder, and right click on the Other Bookmarks folder in here and select Open All in Tabs. I have definitely seen the option there. Over the past week while I have been trying to resolve the issue it has appeared twice. I suspect it has something to do with the sync as I have no other ideas.

Modified by FirefoxUser02

Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8571 solutions 70091 answers

FirefoxUser02 said

If you right click the folder name and select Open All in Tabs, it actually opens all of the items in the root level of your bookmarks and not in the folder itself.

Oh, that sounds very broken. It works on normal folders. Probably they should hide the option for Other Bookmarks in that case.

Maybe someone else will know what's going on.

''FirefoxUser02 [[#answer-1203573|said]]'' <blockquote> If you right click the folder name and select Open All in Tabs, it actually opens all of the items in the root level of your bookmarks and not in the folder itself.</blockquote> Oh, that sounds very broken. It works on normal folders. Probably they should hide the option for Other Bookmarks in that case. Maybe someone else will know what's going on.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8571 solutions 70091 answers

Helpful Reply

One possible reason the item could appear in the folder is if you called the Customize feature in the same window. In fact, if you open and then immediately close Customize, that triggers the "Open All in Tabs" items to appear on the Bookmarks Toolbar and Other Bookmarks fly-outs. Note: The menu only changes in the window where you opened Customize.

So I guess that "bug" could work to your advantage for the time being.

One possible reason the item could appear in the folder is if you called the Customize feature in the same window. In fact, if you open and then immediately close Customize, that triggers the "Open All in Tabs" items to appear on the Bookmarks Toolbar and Other Bookmarks fly-outs. Note: The menu only changes in the window where you opened Customize. So I guess that "bug" could work to your advantage for the time being.
Was this helpful to you? 1
Quote

Question owner

jscher2000 said

One possible reason the item could appear in the folder is if you called the Customize feature in the same window. In fact, if you open and then immediately close Customize, that triggers the "Open All in Tabs" items to appear on the Bookmarks Toolbar and Other Bookmarks fly-outs. Note: The menu only changes in the window where you opened Customize. So I guess that "bug" could work to your advantage for the time being.

Hey, you are right! How did you work that out? Well that does work out well for me.. but I guess I should report the bug?

''jscher2000 [[#answer-1203576|said]]'' <blockquote> One possible reason the item could appear in the folder is if you called the Customize feature in the same window. In fact, if you open and then immediately close Customize, that triggers the "Open All in Tabs" items to appear on the Bookmarks Toolbar and Other Bookmarks fly-outs. Note: The menu only changes in the window where you opened Customize. So I guess that "bug" could work to your advantage for the time being. </blockquote> Hey, you are right! How did you work that out? Well that does work out well for me.. but I guess I should report the bug?
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8571 solutions 70091 answers

Helpful Reply

Someone reported the Customize as a bug, but it was never acted on because someone else couldn't reproduce it. Apparently it is intentional not to show Open All in Tabs there. You could file a bug requesting that it be added, but you might not want to mention the workaround in case it gets "fixed."

Someone reported the Customize as a bug, but it was never acted on because someone else couldn't reproduce it. Apparently it is intentional not to show Open All in Tabs there. You could file a bug requesting that it be added, but you might not want to mention the workaround in case it gets "fixed."
Was this helpful to you? 1
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17336 solutions 156738 answers

Just to be sure that this isn't caused by an extension, did you try Firefox Safe Mode?

Just to be sure that this isn't caused by an extension, did you try Firefox Safe Mode? *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17336 solutions 156738 answers
I'm not sure in what cases Firefox disables this menu item. *https://dxr.mozilla.org/mozilla-release/source/browser/components/places/content/controller.js#589
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.