Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox memory leak?

  • 6 replies
  • 3 have this problem
  • 335 views
  • Last reply by FredMcD

more options

I've been noticing that Firefox becomes very laggy and unresponsive on my high-end desktop, and Windows task manager reveals that a FF thread often takes 3-5 GB of memory that increases over time. This does not show up in FF's task manager.

I haven't been able to identify the cause of this, and it's weird that 3-5 GB of memory will slow things down that much when I still have ~8 GB unused memory.

This is on a pretty fresh Win10 install.

I have tried to attach my about:memory report below, but in case it doesn't go through, I also hosted it on GDrive. https://drive.google.com/open?id=1qyGQShX78PculdEmacm8hO9jqn4E1GWh

Can anyone please help me resolve this issue?

Chosen solution

Hello,

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.

Read this answer in context 👍 0

All Replies (6)

more options

Have you used a memory checking utility?

more options

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

more options

FredMcD said

Start Firefox in Safe Mode {web link} A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Ok so I ran for a few hours in safe mode with Windows Task Manager active, it hovered around 0.8-1 GB ram usage, nothing like before. So I guess this means it's an extension leaking, but is there any way to identify it (e.g. from the memory report above)?

more options

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

more options

A little disappointed that FF's memory reports aren't robust enough to track the issue down, but no matter, it was easy since I don't have that many addons.

Most of my addons added around 50 MB each, but the main culprit was "Google Tradutor - Traduzir para ou de Português", which is strange because I don't remember installing this. I installed English versions of Google Translate add-ons, but somehow got a Portuguese one. Memory now hovers around 1.6-2 GB with the rest of my add-ons, which is still high, but not causing any troubles for now.

more options

Chosen Solution

Hello,

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.