Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

SEC_ERROR_OCSP_MALFORMED_RESPONSE on https://www.google.be and https://www.youtube.com ?

  • 11 replies
  • 0 have this problem
  • 116 views
  • Last reply by FredMcD

more options

Since some days I get SEC_ERROR_OCSP_MALFORMED_RESPONSE on https://www.google.be and https://www.youtube.com I checked all information from Mozilla and on internet but didn't find any solution.Time setting is verified and ok. Other users on the same computer do not have this problem. Has somebody a clue ?

Chosen solution

Tried Safe Mode without success and finally refreshed Firefox (https://support.mozilla.org/en-US/kb/reset-preferences-fix-problems) what took some time and this solved the problem. Afterwards I had to reinstall my themes and extensions and set my preferences again. So happy to be using FF again. This must have been a very strange quirck in my profile to give this kind of error ?

Read this answer in context 👍 0

All Replies (11)

more options
more options

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox from this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.

more options

I checked all the links and none of them brings a solution. I cleared all history, cookies, buffer, ... : no solution. I found a hint directing to Options - Privacy & Security - Certificates : if I untick 'ask OCSP responder servers ...' I don't get the error anymore. But I'm not sure this is a secure way to use FF Strange only Google related sites give this error when this option is ticked. I tried to find Google's certificate in FF's certif. manager to delete it (after exporting) but I don't find it (?). Two other Windows users on the same computer have ticked 'ask OCSP responder servers ...' and don't get the error ? I have any clue anymore where to look for a solution ...

more options

I used "Forget About This Site" on Google, started FF again : problem is not solved ...

more options

Did you try "Forget About This Site"?

edit: I missed your above reply a few minutes before mine, so this didn't work.


This is likely a problem with OCSP stapling and this faulty response is cached somewhere.

Try to disable OCSP Stapling temporarily by toggling this pref to false on the about:config page to see if that has effect.

  • security.ssl.enable_ocsp_stapling = false

It is best to reset this pref via the right-click context menu to true once you are done testing because this is a security feature.

See also:

Modified by cor-el

more options

Thanks for the hints. I disabled OCSP Stapling but without any effect, even after restarting FF and rebooting the pc. Isn't it strange this happens only with google related sites (google.com, youtube.com, gmail.com) and not with any other sites ?

more options

You can check the connection settings.

  • Options/Preferences -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":


Maybe also do a malware scan.

more options

Thanks for the hints. 'No proxy' was already set. I also looked at all Mozilla support pages (many !), but without success. Complete malware scan has been done. But strangely this afternoon I was able to visit the concerning websites without error. But now, this evening, I get the same error again. I don't understand how that's possible ? I will try again tomorrow to see if it's reproducable (is this correct English ?).

more options

I have been trying at different times but I always got the error SEC_ERROR_OCSP_MALFORMED_RESPONSE when trying to visit https://www.google.* or youtube or gmail. Other users on the same pc don't get the error. I don't know of other sites giving this error. Only if I untick 'ask OCSP responder servers ...' I don't get the error anymore. So I think I have to use another browser untill somebody finds a solution ...

more options

Chosen Solution

Tried Safe Mode without success and finally refreshed Firefox (https://support.mozilla.org/en-US/kb/reset-preferences-fix-problems) what took some time and this solved the problem. Afterwards I had to reinstall my themes and extensions and set my preferences again. So happy to be using FF again. This must have been a very strange quirck in my profile to give this kind of error ?

more options

That was very good work. Well done.