X
Tap here to go to the mobile version of the site.

Support Forum

Bookmarks toolbar disappearing - cause & fix

Posted

I recently experienced this issue, and found no solution on googling it. I noticed too that others had the same issue. Having just experienced and fixed it again, here are my observations;

Cause: I have my Firefox set to remember last session. Occasionally, I X out of my main window not realising that there was an ad popup underneath (even though I use adblock). These ads, for whatever reason, have the ability to hide the bookmarks toolbar in their window. That means when you close and reopen, even if you went to a normal site, the bookmarks stay off. It will persist through reinstalls and all kinds of workarounds in my experience.

Fix: Refresh Firefox. Click the Three lines, Help, then Troubleshooting Information. Here you can manually refresh firefox, and it will open with your bookmarks showing again (and a few minor cosmetic things go to default, so you may have to re-tick menu bar and customise how you like your main buttons to look etc). I didn't try this with anything other than having one tab open on google the last time it happened to me.

Not a question, but hopefully useful for anyone who has experienced this, wasn't sure where else to put it.

I recently experienced this issue, and found no solution on googling it. I noticed too that others had the same issue. Having just experienced and fixed it again, here are my observations; Cause: I have my Firefox set to remember last session. Occasionally, I X out of my main window not realising that there was an ad popup underneath (even though I use adblock). These ads, for whatever reason, have the ability to hide the bookmarks toolbar in their window. That means when you close and reopen, even if you went to a normal site, the bookmarks stay off. It will persist through reinstalls and all kinds of workarounds in my experience. Fix: Refresh Firefox. Click the Three lines, Help, then Troubleshooting Information. Here you can manually refresh firefox, and it will open with your bookmarks showing again (and a few minor cosmetic things go to default, so you may have to re-tick menu bar and customise how you like your main buttons to look etc). I didn't try this with anything other than having one tab open on google the last time it happened to me. Not a question, but hopefully useful for anyone who has experienced this, wasn't sure where else to put it.
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 30.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

More Information

FredMcD
  • Top 10 Contributor
4195 solutions 58556 answers

https://support.mozilla.org/en-US/kb/update-firefox-latest-version?cache=no Did you update Firefox to the latest version 65.0.2 February 28, 2019


Separate Security Issue: Update your Flash Player or remove it using these links; Uninstall Flash Player | Windows {web link} Uninstall Flash Player | Mac {web link}

Note: Windows users should download the ActiveX for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox).

Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX.

Flash Player Version 32.0.0.114

https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download. <Windows Only>

https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

https://support.mozilla.org/en-US/kb/update-firefox-latest-version?cache=no Did you update Firefox to the latest version '''65.0.2''' February 28, 2019 ------------- '''Separate Security Issue:''' Update your Flash Player or remove it using these links; [http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html Uninstall Flash Player | Windows] {web link} [http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-mac-os.html Uninstall Flash Player | Mac] {web link} '''Note: Windows users''' should download the '''ActiveX''' for ''Internet Explorer.'' '''and''' the '''plugin''' for ''Plugin-based browsers'' (like Firefox). '''Note: Windows 8 and Windows 10''' have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX. Flash Player '''Version 32.0.0.114 ''' https://get.adobe.com/flashplayer/ Direct link scans current system and browser '''Note: Other software''' is offered in the download. <Windows Only> https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) '''Note: Other software''' is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration
Was this helpful to you? 0
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17352 solutions 156837 answers

Helpful Reply

Note that this issue can be caused by a problem with using "Restore Previous Session" as the startup setting, so if you restore the session automatically on the next start then try to disable this feature.

  • Options/Preferences -> General -> Startup

Once the Bookmarks Toolbar has reappeared then you can re-enable the "Restore Previous Session" startup setting and check if the Bookmarks Toolbar stays visible on next starts.

Note that this issue can be caused by a problem with using "Restore Previous Session" as the startup setting, so if you restore the session automatically on the next start then try to disable this feature. *Options/Preferences -> General -> Startup Once the Bookmarks Toolbar has reappeared then you can re-enable the "Restore Previous Session" startup setting and check if the Bookmarks Toolbar stays visible on next starts.
Was this helpful to you? 1
Quote
mt3ch 3 solutions 26 answers

Tealtraum said

Cause: I have my Firefox set to remember last session. Occasionally, I X out of my main window not realising that there was an ad popup underneath (even though I use adblock). These ads, for whatever reason, have the ability to hide the bookmarks toolbar in their window. That means when you close and reopen, even if you went to a normal site, the bookmarks stay off. It will persist through reinstalls and all kinds of workarounds in my experience.

I had the same problem due to the same cause - a pop-up window being left as last window to close and Firefox was set to remember sessions.

There was no need to refresh Firefox. I just did as cor-el suggested and the problem was fixed.

''Tealtraum [[#question-1251997|said]]'' <blockquote> Cause: I have my Firefox set to remember last session. Occasionally, I X out of my main window not realising that there was an ad popup underneath (even though I use adblock). These ads, for whatever reason, have the ability to hide the bookmarks toolbar in their window. That means when you close and reopen, even if you went to a normal site, the bookmarks stay off. It will persist through reinstalls and all kinds of workarounds in my experience. </blockquote> I had the same problem due to the same cause - a pop-up window being left as last window to close and Firefox was set to remember sessions. There was no need to refresh Firefox. I just did as cor-el [https://support.mozilla.org/en-US/questions/1251997#answer-1202054 suggested] and the problem was fixed.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.