Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Hi. When saving a webpage shortcut I get a Firefox logo instead of the webpage own logo.

  • 8 replies
  • 1 has this problem
  • 43 views
  • Last reply by Pj

more options

Started a few weeks back.

Attached screenshots

All Replies (8)

more options

Hello pedro.xavier,

My guess is that this extension could be causing the problem :

https://addons.mozilla.org/en-US/firefox/addon/favioli/

(your system details show that you have it installed)

You could disable it (for now) and see if that will make a difference. If it does turn out to be the culprit, you could try to contact the developer of the add-on about it.

more options

Hello McCoy,

Didn't work... when I drag the address bar to the desktop to create a shortcut for a site, the icon is always the firefox logo...

Thks anyway,

PX

more options

The cause is that the computer sees the shortcut as an web address, and uses the default web program's icon for it.

The icon can be changed, but I don't have the knowledge on how to get the websites icon to the computer to use it.

more options

As you say that this only started a few weeks ago, I assume that
you always create a desktop shortcut as described in this article :

https://support.mozilla.org/en-US/kb/create-desktop-shortcut-website (?)

more options

McCoy said

As you say that this only started a few weeks ago, I assume that
you always create a desktop shortcut as described in this article : https://support.mozilla.org/en-US/kb/create-desktop-shortcut-website (?)

That is affirmative. Always created like that. A few weeks ago, suddenly, all shortcuts icons lost the image from the respective internet site and were replaced by the Firefox logo.

more options

Maybe check this pref on the about:config page.

  • browser.shell.shortcutFavicons

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

more options

pedro.xavier said

A few weeks ago, suddenly, all shortcuts icons lost the image from the respective internet site and were replaced by the Firefox logo.

It could be because the icon cache is not updated correctly.

See : https://support.microsoft.com/en-ph/help/2396571/icons-are-changed-unexpectedly-in-windows

more options

BTW, The Twitter Extension you have is no longer needed:

"As of 01/08/2018. Twitter fixed their CSP policy on videos and embedded video players work again on Firefox. You should not need this add-on anymore."