Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I have a problem with mozilla when I open google.

  • 6 replies
  • 1 has this problem
  • 9 views
  • Last reply by FredMcD

more options

It loading something from google and I can't do nothing. Problem is vanishing when I go into incognito mode.

Chosen solution

No way to really tell. It might have been a corrupt file.

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.

Read this answer in context 👍 0

All Replies (6)

more options

Here are the pictures.

more options

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: Tracking Protection {web link}

more options

Nothing helped. I disendabled evey truck blocking option and started firefox in safe mode. Week ago I removed mozila folder from appdata and created new profile. Everything was fine till yesterday.

more options

https://support.mozilla.org/kb/Clear+Recent+History#w_how-do-i-remove-a-single-website-from-my-history

Remove History For One Site

Open the History Manager <Control><Shift> H. In the search bar, enter the name of the site. Right-click on one of the listings and select Forget About This Site. This should remove all information, including any passwords / settings.

more options

Thank u! Now it's working. Can u tell me why does it happened?

more options

Chosen Solution

No way to really tell. It might have been a corrupt file.

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.