Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox forcing images to be saved as .webp; changes to about:config don't work. Help?

  • 5 replies
  • 1 has this problem
  • 37 views
  • Last reply by cor-el

more options

I need to be able to save .gif images as .gifs, not .webp. Changing these in about:config don't work:

image.webp.enabled = true

image.http.accept = image/webp,*/*

network.http.accept.default = text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8

Would reverting back to an older version of Firefox fix it? Is there some other solution? This is very frustrating.

Modified by ccgift1

All Replies (5)

more options

You need to remove ,image/webp from the accept pref.

  • image.http.accept = */*
  • network.http.accept.default = text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
more options

I did that already and it didn't work. Is there something else I can try?

Modified by ccgift1

more options

ccgift1 said

I did that already and it didn't work. Is there something else I can try?

Hello ccgift1,

You marked cor-el's post as Chosen Solution - does that mean it did work after all  ?

more options

Web pages shouldn't send WebP images when you do not request them via the accept headers.

You marked my above reply as the solution. Does this mean that you got it to work. I don't know if you need to close and restart Firefox to make the changes work.

more options

What are the current settings of the webp prefs?