X
Tap here to go to the mobile version of the site.

Support Forum

Usernames and passwords are not saved

Posted

this happened previously and some-one suggested going back to a previous version of Firefox which solved it but it has stopped saving passwords again. How to go back again please?

this happened previously and some-one suggested going back to a previous version of Firefox which solved it but it has stopped saving passwords again. How to go back again please?
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

More Information

TedT_USA 0 solutions 10 answers

PASSWORDS NOT BEing SAVED OR NOT BEING ASKED TO BE SAVED [ FF 65.0.1 ] My logins.json file became corrupted. I deleted the file and started to rebuild it. (My backup didn’t work). OK, I logged onto a few sites. Then, I encountered this behavior: (1) On some sites, FF would pop-up and ask if I wanted to save the password = great, (2) on some sites, I was not asked to save the password the first time that I open the site, but if I closed the site’s webpage, and logged in again, the 2nd time FF asked if I wanted to save the password, AND (3) some sites, I type the password, no pop-up appears and regardless of the number of times i logout and reopen site the pop-up does not appear. The anomaly appears in both normal and private browsing mode. The Option is set [ x ] Ask to save logins and passwords for websites. Yes, when I started fresh, the Saved Logins was blank. Yes, cache was cleared. Yes, the cookies for the sites wherein the save password pop-up did not appear were cleared. Yes, I’ve restarted FF several times Nope, have not added any new add-ons. Yes, disabled add-on with no change in behavior Nope, there websites are not in the save password exception list. Yes, FF is set to remember history Nope, do not have third-party password manager

PASSWORDS NOT BEing SAVED OR NOT BEING ASKED TO BE SAVED [ FF 65.0.1 ] My logins.json file became corrupted. I deleted the file and started to rebuild it. (My backup didn’t work). OK, I logged onto a few sites. Then, I encountered this behavior: (1) On some sites, FF would pop-up and ask if I wanted to save the password = great, (2) on some sites, I was not asked to save the password the first time that I open the site, but if I closed the site’s webpage, and logged in again, the 2nd time FF asked if I wanted to save the password, AND (3) some sites, I type the password, no pop-up appears and regardless of the number of times i logout and reopen site the pop-up does not appear. The anomaly appears in both normal and private browsing mode. The Option is set [ x ] Ask to save logins and passwords for websites. Yes, when I started fresh, the Saved Logins was blank. Yes, cache was cleared. Yes, the cookies for the sites wherein the save password pop-up did not appear were cleared. Yes, I’ve restarted FF several times Nope, have not added any new add-ons. Yes, disabled add-on with no change in behavior Nope, there websites are not in the save password exception list. Yes, FF is set to remember history Nope, do not have third-party password manager
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17273 solutions 156141 answers

As posted above, you either have disabled Password Manager or are possibly using Private Browsing mode as the main causes.

  • Options/Preferences -> Privacy & Security: Forms & Passwords: "Remember logins for sites"

Make sure you do not run Firefox in permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History).

  • Options/Preferences -> Privacy & Security
    Firefox will: "Use custom settings for history"
  • remove checkmark: [ ] "Always use Private Browsing mode"

Another possible cause is using an external Password Manager or your security software disable this feature.

As posted above, you either have disabled Password Manager or are possibly using Private Browsing mode as the main causes. *Options/Preferences -> Privacy & Security: Forms & Passwords: "Remember logins for sites" Make sure you do not run Firefox in permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History). *https://support.mozilla.org/en-US/kb/private-browsing-use-firefox-without-history *Options/Preferences -> Privacy & Security<br>Firefox will: "Use custom settings for history" *remove checkmark: [ ] "Always use Private Browsing mode" Another possible cause is using an external Password Manager or your security software disable this feature.
Was this helpful to you? 1
Quote

Helpful Reply

As previously stated above, I have checked all the Options and they are fine, have no external things either, this happened after FF had updated and others had also posted this problem. The response was to go back to the previous FF version and that worked fine, but now it has done it again and I do not remember how to go back to an earlier version. This may well help Ted T too if some-one can let us know how to go back to older version. Thanks anyway.

As previously stated above, I have checked all the Options and they are fine, have no external things either, this happened after FF had updated and others had also posted this problem. The response was to go back to the previous FF version and that worked fine, but now it has done it again and I do not remember how to go back to an earlier version. This may well help Ted T too if some-one can let us know how to go back to older version. Thanks anyway.
Was this helpful to you? 1
Quote
McCoy
  • Top 10 Contributor
466 solutions 4252 answers

Helpful Reply

@ TedT_USA :

Stab in the dark, but this might be the case on those few sites : The login page on those websites may be containing a piece of code that is used as a standard to tell the web browser not to prompt the user to save the password for security reasons. (added source code to the password input box that has an autocomplete=”off”)

See : https://developer.mozilla.org/en-US/docs/Web/Security/Securing_your_site/Turning_off_form_autocompletion

You could remove 'autocomplete=off' with a bookmarklet to have Firefox save username and password ......

See :

http://kb.mozillazine.org/User_name_and_password_not_remembered

I've never tried it myself .....

@ TedT_USA : Stab in the dark, but this might be the case on those few sites : The login page on those websites may be containing a piece of code that is used as a standard to tell the web browser not to prompt the user to save the password for security reasons. (added source code to the password input box that has an autocomplete=”off”) See : https://developer.mozilla.org/en-US/docs/Web/Security/Securing_your_site/Turning_off_form_autocompletion You could remove 'autocomplete=off' with a bookmarklet to have Firefox save username and password ...... See : http://kb.mozillazine.org/User_name_and_password_not_remembered I've never tried it myself .....
Was this helpful to you? 1
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17273 solutions 156141 answers

Do you mean saving new passwords in the Password Manager or make website remembering you and automatically log you in?

The later is about special cookies, so check the cookie settings and possible "Clear history when Firefox closes" setting if you have this feature enabled.

Do you mean saving new passwords in the Password Manager or make website remembering you and automatically log you in? The later is about special cookies, so check the cookie settings and possible "Clear history when Firefox closes" setting if you have this feature enabled.
Was this helpful to you? 1
Quote
TedT_USA 0 solutions 10 answers

The websites that did present the “save password” pop-up now provide the pop-up and the passwords are saved. I did a “clean install”. Thanks all for your suggestion(s) that I received. Having already performed a substantial number of tests, I elected to forge additional tests and just proceed with a clean install of FF 65.0.1, after deleting all the directories as I have the program on C:\ and the profile on D:\. And the “purge” included the complete deletion of my “cache” folder which is on my H:\ drive. Using “SearchMyFiles”, I found any other Firefox file references and deleted those as well.

  1. After installing FF sans add-ons I tried some websites and the “save password” pop-up worked.
  2. Then, I relocated my profile to my D:\ drive and assigned cache to my H:\ drive. Tested again w/o add-ons and all worked.
  3. Now for the big jump; after saving my new profile’s “logins.json” and “key4.db” files, I moved my older “logins.json” and “key4.db” into the new profile. Tested again, and all worked.
  4. Next, I downloaded and added my list of add-ons one by one as I have a slate of 19 enabled add-ons. After each add-on, I tested and all worked. Nope, I did not amend the list.
  5. The conclusions: CWT = Cleared While Testing, a communication industry acronym when there’s a circuit issue and the technician makes no change; however, the testing cleared the issue. In this case, my deduction is that the in-place upgrade from 65.0.0 to 65.0.1 might have corrupted a file. By clearing every last vestige of Firefox files (except “logins.json” and “key4.db” as I noted), a true clean install occurred.
  6. Time expended = 90 minutes.

Thanks again folks.

= = =

To recap. Everything is working, e.g.: passwords are saved for the sites. Nope, no external password manager Nope, not running permanently in “private mode”. Yes, the anomaly occurred in both “private mode” and regular mode.

''The websites that did present the “save password” pop-up now provide the pop-up and the passwords are saved. I did a “clean install”.'' '''Thanks all for your suggestion(s) that I received.''' Having already performed a substantial number of tests, I elected to forge additional tests and just proceed with a clean install of FF 65.0.1, after deleting all the directories as I have the program on C:\ and the profile on D:\. And the “purge” included the complete deletion of my “cache” folder which is on my H:\ drive. Using “SearchMyFiles”, I found any other Firefox file references and deleted those as well. # After installing FF sans add-ons I tried some websites and the “save password” pop-up worked. # Then, I relocated my profile to my D:\ drive and assigned cache to my H:\ drive. Tested again w/o add-ons and all worked. # Now for the big jump; after saving my new profile’s “logins.json” and “key4.db” files, I moved my older “logins.json” and “key4.db” into the new profile. Tested again, and all worked. # Next, I downloaded and added my list of add-ons one by one as I have a slate of 19 enabled add-ons. After each add-on, I tested and all worked. Nope, I did not amend the list. # The conclusions: CWT = Cleared While Testing, a communication industry acronym when there’s a circuit issue and the technician makes no change; however, the testing cleared the issue. In this case, my deduction is that the in-place upgrade from 65.0.0 to 65.0.1 might have corrupted a file. By clearing every last vestige of Firefox files (except “logins.json” and “key4.db” as I noted), a true clean install occurred. # Time expended = 90 minutes. Thanks again folks. = = = = = To recap. Everything is working, e.g.: passwords are saved for the sites. Nope, no external password manager Nope, not running permanently in “private mode”. Yes, the anomaly occurred in both “private mode” and regular mode.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.