Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 65 stays in memory

  • 12 replies
  • 1 has this problem
  • 45 views
  • Last reply by FredMcD

more options

I noticed that firefox stays in memory after I close it. In fact, If I open and close firefox 10 times, ten processes are shown in memory, each consuming around 100Mb.

I'm using Windows 7 in my corporate computer and I have been using Firefox 65.0.1 x64. I've tried to use it in safe mode (no add-ons) and problem persisted. I uninstalled it, deleted all Mozilla data in AppData and ProgramData and reinstalled it fresh. The problem persisted.

Then I installed the 32-bit version of Firefox and the problem is no more. Is it a bug that has to be fixed or some setting that shoudn't be enabled?

Thank you.

Modified by nelsonwcf

Chosen solution

Hi FredMcD,

Just for a closure in this case, I won't be able to test these steps because my laptop has been updated to Windows 10. So far, it is not showing this issue anymore.

Will open another question if this starts to happen again.

Thanks for your help.

Read this answer in context 👍 0

All Replies (12)

more options

I would like a knowledgeable FF user please tell me the pros and cons of using FF 32-Bit vs 64-Bit on a Win-7 64-Bit system?

(I think I had the answer to this before, bookmarked/noted in the 'old' Description Field, but I just checked/searched and came up with nothing - since the Description Field is no longer viewable in FF.)


~Pj

more options

Let's try an experiment.

1) Reboot the Computer.

2) Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh).

3) Close the browser. Give it about 20 seconds to finnish closing. Then restart again in Safe Mode.

4) Do this several times. Is the problem still there?

more options

Use one of these to close Firefox if you are currently doing that by clicking the close X on the Firefox title bar.

  • "3-bar" menu button -> Exit (Power button)
  • Windows: File -> Exit
  • Mac: Firefox -> Quit Firefox
  • Linux: File -> Quit

Are you using "Clear history when Firefox closes" to clear personal data?

more options

FredMcD said

Let's try an experiment. 1) Reboot the Computer. 2) Start Firefox in Safe Mode {web link} A small dialog should appear. Click Start In Safe Mode (not Refresh). 3) Close the browser. Give it about 20 seconds to finnish closing. Then restart again in Safe Mode. 4) Do this several times. Is the problem still there?

Yes, the problem is still there. It doesn't matter if it is in safe mode or regular mode; firefox stays in memory even after closing. Check the picture.

more options

cor-el said

Use one of these to close Firefox if you are currently doing that by clicking the close X on the Firefox title bar.
  • "3-bar" menu button -> Exit (Power button)
  • Windows: File -> Exit
  • Mac: Firefox -> Quit Firefox
  • Linux: File -> Quit
Are you using "Clear history when Firefox closes" to clear personal data?

Nothing changed. No, I'm not using the clear history option.

more options

do you get a crash report 1 minute after closing firefox? if yes, could you please enter about:crashes into the address bat and provide an id of the most recent submitted report starting with bp? thank you

more options

No, it doesn't crash. Just stays in memory.

more options

Okay, let's try going thru the back door.

Open your text editor and create a file called; Firefox_TaskKill.bat and place it on your hard drive and make a shortcut to place on your desktop.


Echo Off Echo. Echo TASKKILL /T /IM Firefox.exe Echo. TASKKILL /T /IM Firefox.exe Echo %errorlevel% If errorlevel 256 goto Continue If errorlevel 255 goto End

Continue

Echo. Echo Waiting Echo. C:\PROGRA~2\NirSoft\NirCmd\nircmd.exe wait 14000 Echo. Echo TASKKILL Forced Echo. TASKKILL /T /F /IM Firefox.exe Pause Call C:\Users\Fred\DOCUME~1\DELSES~1.BAT Pause

End

Exit

more options

It did not post as I wanted it to.

Continue

should be :Continue

and remove this from the bottom; Call C:\Users\Fred\DOCUME~1\DELSES~1.BAT

more options

And C:\PROGRA~2\NirSoft\NirCmd\nircmd.exe wait 14000 is a program I use to pause the program for a few seconds.

more options

Chosen Solution

Hi FredMcD,

Just for a closure in this case, I won't be able to test these steps because my laptop has been updated to Windows 10. So far, it is not showing this issue anymore.

Will open another question if this starts to happen again.

Thanks for your help.

more options

Let's hope it does not return. Please flag your last post as Solved Problem so others will know.