Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Language settings and display

  • 7 replies
  • 2 have this problem
  • 15 views
  • Last reply by FredMcD

more options

FF Quantum 65.0 (64-bit) on Debian 9

Language set to English (UK English where available); but for some weeks now, FF has been displaying some text in Marathi. Screen shot attached. This happens with the results of a search through Google. The phenomenon is not seen in the Opera browser even when the search engine and the web page are the same.

Attached screenshots

Chosen solution

English is the language specified in Google preferences and I do not use a proxy or a VPN. I think I have solved the problem by moving back to Firefox ESR. Thank you for your time.

Read this answer in context 👍 0

All Replies (7)

more options

Sign into Google and check that the settings are English.

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

more options

You can try to clear the Google cookies. You can also check the Google settings page.

What is the order of the languages send by Firefox?

  • Options/Preferences -> General -> Languages
more options

Thank you, Fred. I did all that you suggested, but nothing changed. Marathi text still appears in places.

Thank you, cor-el. Cookies and many other things are cleared when FF is shut down. First language, English (UK), second Eng. (US)

more options

Looks like I must wait for the next release.

more options

Did you check the Google preferences page?

Are you possibly using a VPN or proxy that could cause this?

more options

Chosen Solution

English is the language specified in Google preferences and I do not use a proxy or a VPN. I think I have solved the problem by moving back to Firefox ESR. Thank you for your time.

more options

That was very good work. Well done. Please flag your last post as Solved Problem so others will know.