Search Support

Pocket (which I turned OFF) grabs ALL my bookmarks so I have to edit them into my bookmarks list; can I completely disable it?

  • 4 replies
  • 1 has this problem
  • 17 views
  • Last reply by DrDave

more options

Pocket was OK for a while, but about a week or so ago it started taking the URL whenever I clicked on Bookmarks in the Firefox menu (on a Mac running 10.12.6). I keep my bookmarks organized in a folder structure, so this makes me go back to the Bookmarks menu and choose Edit This Bookmark. I changed the value given in the instructions to disable it to FALSE as instructed, and restarted Firefox just in case. BUT it still acts the same way, grabbing the Bookmarks. I don't WANT Pocket. If anyone can tell me how to get it to stop working I would really appreciate it. Thank you for any help.

Chosen solution

Ok, I see. The Library is just the default place that bookmarks are visible. It was a change made a while ago by the Firefox developers. Personally, I'm not a fan of that menu either.

The bright side is that you can put back the Bookmarks Menu button that was there previously. You can customize your Firefox layout and drag the bookmark menu button on the toolbar and drag the Library icon off of the toolbar.

This should make the bookmarks look the way that you are probably used to.

Read this answer in context 👍 0

All Replies (4)

more options

I'm not quite sure what you are describing with in your post, but it doesn't sound like it has anything to do with Pocket. Pocket doesn't view or edit your bookmarks at all.

In any case, if you want to disable Pocket, do the following:

  1. Type about:config in your Firefox address bar
  2. Bypass the security warning
  3. Find the extensions.pocket.enabled preference
  4. Set it to false by double-clicking it
  5. Restart Firefox

From your original post, it sounds like you've already done this. If that's the case, it's almost certainly not a Pocket-related issue, since that completely disables Pocket in Firefox. You shouldn't even see Pocket in your Library menu if you have done the above.

more options

Thanks Wesley. Yes, I did do all of those things. After rebooting the only change is that I don't see the Pocket icon any more. However, when I try to Bookmark a page as soon as I click on "Bookmark this page" I get "Saved to Library". Maybe "Library" is not Pocket after all. If not though, what the heck is it and why is it taking all of my bookmarks? It's annoying.

Again, thank you for your help.

more options

Chosen Solution

Ok, I see. The Library is just the default place that bookmarks are visible. It was a change made a while ago by the Firefox developers. Personally, I'm not a fan of that menu either.

The bright side is that you can put back the Bookmarks Menu button that was there previously. You can customize your Firefox layout and drag the bookmark menu button on the toolbar and drag the Library icon off of the toolbar.

This should make the bookmarks look the way that you are probably used to.

more options

Thank you so much Wesley! I really appreciate your help. You made my day. I hope I can be as helpful in this group. Have a wonderful weekend.