X
Tap here to go to the mobile version of the site.

Support Forum

Exception to "Delete cookies and site data when Firefox is closed"

Posted

Dear all,

I want Firefox to automatically remove cookies and site data, when Firefox is closed (which I'm able to do), but I'd like to have some exception, so that my Google Search Settings or WebWhatsapp configuration is not deleted.

In the past, it was possible to do (and there are many threads, where it is explained), but the the current version of Firefox, does not seem to easily allow it. If 'I go to "about:preferences#privacy" and then to "Cookies and Site Data", I only have the following options "Clear Data", "Manage Data", "Manage Permissions" as well as "Delete cookies and site data when Firefox is closed" (which is an "all or nothing" instruction). There seems to be no way to customize that specific cookies don't be deleted, as it was possible in the past, at least not here.

Dear all, I want Firefox to automatically remove cookies and site data, when Firefox is closed (which I'm able to do), but I'd like to have some exception, so that my Google Search Settings or WebWhatsapp configuration is not deleted. In the past, it was possible to do (and there are many threads, where it is explained), but the the current version of Firefox, does not seem to easily allow it. If 'I go to "about:preferences#privacy" and then to "Cookies and Site Data", I only have the following options "Clear Data", "Manage Data", "Manage Permissions" as well as "Delete cookies and site data when Firefox is closed" (which is an "all or nothing" instruction). There seems to be no way to customize that specific cookies don't be deleted, as it was possible in the past, at least not here.
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

More Information

McCoy
  • Top 10 Contributor
465 solutions 4238 answers

Hello sfbb,

When you're on the site(s) where you don't want cookies deleted, click on the 'i' in a circle, next to the padlock at the left side of the address bar.

Then click on the little black arrow on the dropdown and then on "More Information", which will take you to "Page Info".

Click on the 'Permissions" tab and scroll down to "Set Cookies". Uncheck "Use Default" and check "Allow".

Then close and restart Firefox.

Hello sfbb, When you're on the site(s) where you don't want cookies deleted, click on the 'i' in a circle, next to the padlock at the left side of the address bar. Then click on the little black arrow on the dropdown and then on "More Information", which will take you to "Page Info". Click on the 'Permissions" tab and scroll down to "Set Cookies". Uncheck "Use Default" and check "Allow". Then close and restart Firefox.
Was this helpful to you? 0
Quote

Question owner

It does not solve the problem.

Now, gmail, google search, hotmail and whatsapp all have an extra permission to set cookies, but my log-in information is deleted anyway every time I close Firefox.

It does not solve the problem. Now, gmail, google search, hotmail and whatsapp all have an extra permission to set cookies, but my log-in information is deleted anyway every time I close Firefox.
Was this helpful to you? 0
Quote
frtz 1 solutions 3 answers

I have the same problem. All the websites I have made an exception for in the past, are still in the latest version of Firefox, but every time I open these sites, I first have to agree with their cookie and privacy statements.

I tried everything, including the above mentioned, but to no avail. Very annoying!

I have the same problem. All the websites I have made an exception for in the past, are still in the latest version of Firefox, but every time I open these sites, I first have to agree with their cookie and privacy statements. I tried everything, including the above mentioned, but to no avail. Very annoying!
Was this helpful to you? 0
Quote
FredMcD
  • Top 10 Contributor
4147 solutions 57893 answers

Helpful Reply

Your ‘logged-in’ status is stored in special cookies. If the cookie is removed, you are logged out.

Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings.

At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.

Your ‘logged-in’ status is stored in special cookies. If the cookie is removed, you are logged out. Type '''about:preferences#privacy'''<enter> in the address bar. The button next to '''History, ''' select '''Use Custom Settings. ''' At the bottom of the page, turn on '''Clear History When Firefox Closes. ''' At the far right, press the '''Settings''' button. Turn on ONLY '''Cache''' and '''Form And Search History''' leaving the others off.
Was this helpful to you? 1
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17269 solutions 156091 answers

Helpful Reply

When you use "Delete cookies and site data when Firefox is closed" to remove cookies then you should keep cookies with an allow exception. You may have to add more domains yourself if the website uses them. Make sure to prefix the correct protocol (https or http).

When you use "Delete cookies and site data when Firefox is closed" to remove cookies then you should keep cookies with an allow exception. You may have to add more domains yourself if the website uses them. Make sure to prefix the correct protocol (https or http). *https://developer.mozilla.org/en-US/Tools/Storage_Inspector
Was this helpful to you? 1
Quote
frtz 1 solutions 3 answers

I did what you both suggested and also renewed the exceptions. It now works fine. Thanks for your help!

I did what you both suggested and also renewed the exceptions. It now works fine. Thanks for your help!
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4147 solutions 57893 answers

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily. Thank you for contacting Mozilla Support.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.