X
Tap here to go to the mobile version of the site.

Support Forum

Firefox crashes

Posted

'm trying to get Firefox to launch but it only runs in background. It apparently crashed last night but I think the report disappeared (?). There's an installation time number. Antivirus/malware is clean and the app is allowed by Avast and Windows Defender. It was crashing my laptop repeatedly throughout the day (I think).


After turning it off in background using Task Manager whenever it would open, I tried to access it several ways... creating a new profile (opens in background only), checking shortcut pathways, deleting a potentially corrupted program file, and doing a clean install (starting with downloading a new installation). The clean install sort of works --when I try to open it, it now asks for my permission to make a change to the computer. I click yes, but it still won't open. That message shows repeatedly.

Also tried Windows compatibility troubleshooter and it found nothing (but it says it's for Windows Vista (no option for Windows 10).

Thanks for any thoughts : )

'm trying to get Firefox to launch but it only runs in background. It apparently crashed last night but I think the report disappeared (?). There's an installation time number. Antivirus/malware is clean and the app is allowed by Avast and Windows Defender. It was crashing my laptop repeatedly throughout the day (I think). After turning it off in background using Task Manager whenever it would open, I tried to access it several ways... creating a new profile (opens in background only), checking shortcut pathways, deleting a potentially corrupted program file, and doing a clean install (starting with downloading a new installation). The clean install sort of works --when I try to open it, it now asks for my permission to make a change to the computer. I click yes, but it still won't open. That message shows repeatedly. Also tried Windows compatibility troubleshooter and it found nothing (but it says it's for Windows Vista (no option for Windows 10). Thanks for any thoughts : )
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/64.0.3282.140 Safari/537.36 Edge/17.17134

More Information

FredMcD
  • Top 10 Contributor
4025 solutions 56247 answers

https://support.mozilla.org/en-US/kb/changes-toolbars-and-window-sizes-are-not-saved You may have corrupt xulstore.json or Localstore.rdf files.

Close Firefox. Open your file browser to this hidden location:

  • Mac: *~/Library/Application Support/Firefox/Profiles
  • Linux: *~/.mozilla/firefox/Profiles
  • Windows: %AppData%\Mozilla\Firefox\Profiles
  • *C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles
  • Windows XP: C:\Documents and Settings\<user>\Application Data
    \Mozilla\Firefox\Profiles\

Search for the above files. Then rename or delete them. Restart Firefox.


Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

https://support.mozilla.org/en-US/kb/changes-toolbars-and-window-sizes-are-not-saved You may have corrupt '''xulstore.json''' or '''Localstore.rdf''' files. '''Close Firefox. ''' Open your file browser to this hidden location: * '''Mac: ''' *~/Library/Application Support/Firefox/Profiles * '''Linux: ''' *~/.mozilla/firefox/Profiles * '''Windows: ''' %AppData%\Mozilla\Firefox\Profiles * *C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles * '''Windows XP: ''' C:\Documents and Settings\<user>\Application Data<br> \Mozilla\Firefox\Profiles\ Search for the above files. Then rename or delete them. Restart Firefox. ---------------- [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?
Was this helpful to you?
Quote

Question owner

Thanks for the reply : ) Sorry, I already deleted xulstore.json. Localstore.rdf wasn't there. I had also tried opening Firefox in safe mode by holding shift key while clicking on shortcut. It is running in the background, so I close it with task manager every time I try something different.

Thanks for the reply : ) Sorry, I already deleted xulstore.json. Localstore.rdf wasn't there. I had also tried opening Firefox in safe mode by holding shift key while clicking on shortcut. It is running in the background, so I close it with task manager every time I try something different.
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4025 solutions 56247 answers

Helpful Reply

Let’s do a full clean re-install;

Download Firefox For All languages And Systems {web link}

Save the file. Then Close Firefox.

Using your file browser, open the Programs Folder on your computer.

Windows: C:\Program Files C:\Program Files (x86) Note: Check Both Folders

Mac: Open the "Applications" folder. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac

Linux: Check your user manual. If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it. See Install Firefox on Linux; https://support.mozilla.org/en-US/kb/install-firefox-linux

If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory. http://www.mozilla.org/firefox#desktop ++++++++++++++++++++++++++++ Look for, and remove any Mozilla or Firefox program folders. Do not remove the Mozilla Thunderbird folder if there is one.

Do Not remove any profile folders.

After rebooting the computer, run a registry scanner if you have one. Then run the installer. +++++++++++++++++++++++++++ If there is a problem, start your Computer in safe mode and try again.

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode This shows how to Start all Computers in Safe Mode; Free Online Encyclopedia

Let’s do a full clean re-install; [http://www.mozilla.org/en-US/firefox/all/ Download Firefox For All languages And Systems] {web link} Save the file. Then '''Close Firefox. ''' Using your file browser, open the '''Programs Folder''' on your computer. '''Windows: ''' C:\Program Files C:\Program Files (x86) '''Note:''' Check Both Folders '''Mac: ''' Open the ''' "Applications" ''' folder. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac '''Linux: ''' Check your user manual. If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it. See Install Firefox on Linux; https://support.mozilla.org/en-US/kb/install-firefox-linux If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory. http://www.mozilla.org/firefox#desktop ++++++++++++++++++++++++++++ Look for, and remove any '''Mozilla''' or '''Firefox''' program folders. Do not remove the '''Mozilla Thunderbird''' folder if there is one. '''Do Not''' remove any profile folders. After rebooting the computer, run a registry scanner if you have one. Then run the installer. +++++++++++++++++++++++++++ If there is a problem, start your '''Computer''' in safe mode and try again. http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode This shows how to Start all Computers in Safe Mode; Free Online Encyclopedia
Was this helpful to you? 1
Quote
cor-el
  • Top 10 Contributor
  • Moderator
16992 solutions 153425 answers

Helpful Reply

Check that Firefox isn't set to run as Administrator.

You can open the Properties of the Firefox desktop shortcut via the right-click context menu and check the "Compatibility" tab.

Make sure all items are deselected in the "Compatibility" tab of the Properties window.

  • Privilege Level: "Run this program as Administrator" should not be selected
  • "Run this program in compatibility mode for:" should not be selected

Also check the Properties of the firefox.exe program in the Firefox program folder.


Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.

Check that Firefox isn't set to run as Administrator. You can open the Properties of the Firefox desktop shortcut via the right-click context menu and check the "Compatibility" tab. Make sure all items are deselected in the "Compatibility" tab of the Properties window. *Privilege Level: "Run this program as Administrator" should not be selected *"Run this program in compatibility mode for:" should not be selected Also check the Properties of the firefox.exe program in the Firefox program folder. ---- Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/ *http://www.7tutorials.com/4-ways-boot-safe-mode-windows-10
Was this helpful to you? 1
Quote

Question owner

Thanks for the replies : )

I unchecked admin/compatibility boxes in properties window. Firefox then ran in background like before, without asking permission to make changes to computer.

Then I opened Firefox in Windows safe mode. It ran in the background. This time I was able to access my Firefox profile using firefox.exe -P. I renamed my profile and Firefox ran in background, but when I created a new profile, Firefox opened and ran with the new profile. It ran ok in Windows safe mode and normal mode.

At that point, I decided to try a free trial of product to clean up/optimize because computer slowdown/crashes and Firefox problem coincided. It said there was one app causing crashes that needed updating, Firefox, and updated that. Plus, it cleaned stuff... scanned the registry. Thanks!!

Thanks for the replies : ) I unchecked admin/compatibility boxes in properties window. Firefox then ran in background like before, without asking permission to make changes to computer. Then I opened Firefox in Windows safe mode. It ran in the background. This time I was able to access my Firefox profile using firefox.exe -P. I renamed my profile and Firefox ran in background, but when I created a new profile, Firefox opened and ran with the new profile. It ran ok in Windows safe mode and normal mode. At that point, I decided to try a free trial of product to clean up/optimize because computer slowdown/crashes and Firefox problem coincided. It said there was one app causing crashes that needed updating, Firefox, and updated that. Plus, it cleaned stuff... scanned the registry. Thanks!!
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.