X
Tap here to go to the mobile version of the site.

Support Forum

Getting error code: SSL_ERROR_RX_RECORD_TOO_LONG

Posted

Trying to open Spotify on my iMac. I have the latest Firefox installed. I keep getting the Error code: SSL_ERROR_RX_RECORD_TOO_LONG Screenshot attached Thanks

Trying to open Spotify on my iMac. I have the latest Firefox installed. I keep getting the Error code: SSL_ERROR_RX_RECORD_TOO_LONG Screenshot attached Thanks

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:65.0) Gecko/20100101 Firefox/65.0

More Information

philipp
  • Top 25 Contributor
  • Moderator
5280 solutions 23329 answers

hi, are you using avast security software on the affected system by any chance?

hi, are you using avast security software on the affected system by any chance?

Question owner

Hi Philip. No I do not have avast security software installed. I'm using an iMac. John

Hi Philip. No I do not have avast security software installed. I'm using an iMac. John
philipp
  • Top 25 Contributor
  • Moderator
5280 solutions 23329 answers

ok, the problem i usually caused though when something on the system or network is intercepting/meddling with encrypted network traffic though. could you run a test and see if the problem is still occurring when you enter about:config into the firefox address bar (confirm the info message in case it shows up), search for the preference named security.tls.version.max and then double-click it and change its value to 3 - this is only for diagnosing the matter and no permanent solution as it will decrease the strength of secure connections in the long run...

ok, the problem i usually caused though when something on the system or network is intercepting/meddling with encrypted network traffic though. could you run a test and see if the problem is still occurring when you enter '''about:config''' into the firefox address bar (confirm the info message in case it shows up), search for the preference named '''security.tls.version.max''' and then double-click it and change its value to '''3''' - this is only for diagnosing the matter and no permanent solution as it will decrease the strength of secure connections in the long run...

Question owner

OK, I did all that decreasing the value from 4 to 3. I am logged into Spotify but when I try to download the desktop app, I keep getting the same Error code...

OK, I did all that decreasing the value from 4 to 3. I am logged into Spotify but when I try to download the desktop app, I keep getting the same Error code...
philipp
  • Top 25 Contributor
  • Moderator
5280 solutions 23329 answers

hm, in this case i'm starting to run out of ideas slowly. in any case you should go back into about:config and reset that preference to its default value 4. do you know of any other proxy/vpn software on your system or network that might cause interference with network traffic?

hm, in this case i'm starting to run out of ideas slowly. in any case you should go back into about:config and reset that preference to its default value 4. do you know of any other proxy/vpn software on your system or network that might cause interference with network traffic?

Question owner

Thanks for your advice. I'll have to forego Spotify on my desktop. Still, I have it on my phone, not all bad! John

Thanks for your advice. I'll have to forego Spotify on my desktop. Still, I have it on my phone, not all bad! John
cor-el
  • Top 10 Contributor
  • Moderator
17336 solutions 156740 answers

Did you close (Quit) and restart Firefox after modifying security.tls.version.max ?

Did you close (Quit) and restart Firefox after modifying security.tls.version.max ?

Question owner

Sorry about the delay in replying to your last post. I had not closed down and restarted. Just did so and all is well. Thanks for your help, much appreciated.

Sorry about the delay in replying to your last post. I had not closed down and restarted. Just did so and all is well. Thanks for your help, much appreciated.