Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox removes spaces as I type

  • 8 replies
  • 1 has this problem
  • 7 views
  • Last reply by Mark

more options

Starting 3-4 days ago, I can't type reliably on 1 specific website: - on any page on this website (CVMG.ca), I type a word, hit space, then start another word the space is removed and the words join together - if I add 2-3 more spaces, the same thing happens - all the spaces are removed when I start typing the next word - if I hold down the space bar and let auto-space insert (6-8 spaces), the next word types correctly (no spaces are removed) - this occurs when using Firefox 64.0.2 on a Mac running OS X 10.14.2 - it seems to happen only on one website - I can enter words on other sites on this browser (such as what I'm typing now) - Typing works normally when I access the website from Safari. - There's a similar problem described on github for Firefox support that relates to a change in CSS. - see attached screenshot - t shows a reply typed into a general forum gadget, but the same thing happens when I type into any other entry space on that website. - I have filed a similar trouble ticket with the web hosting service

Attached screenshots

All Replies (8)

more options

Since that is a login site until someone with that account using firefox to test that is the only way to find what happens.

more options

That is very odd. I might suspect malware if this happens on other websites.

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

more options

Um, sorry. Try this: - login to cvmg.ca as test@cvmg.ca password is firefoxtest - in the left side menu, click Firefox test - it has a test forum page with freeform text you can use to re-create the problem - click Create topic and give it a try

while preparing this test, it seems that only freeform text on this website is affected. So, typing something into the Subject line behaves correctly, but typing in the freeform text box removes spaces as I type.

more options

FredMcD said

That is very odd. I might suspect malware if this happens on other websites. Many site issues can be caused by corrupt cookies or cache. Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website. If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help? While you are in safe mode; Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches. How to disable Hardware Acceleration {web link}

I tried Safe mode and graphics hardware acceleration suggestions, the results don't vary (I ran tests for each case you can see results on the test page described above). I cleared cache before posting the original problem, then several times throughout these threads. No improvement.

I am reluctant to wipe all cookies as there's lots of good stuff there. Maybe I'll try to backup things first.

I didn't mention that this problem occurs on 2 Macs both running the latest OS X release. Oh, and 2 extensions (Ghostery and Grammarly) are installed but disabled.

more options

Access denied (error 403)

more options

FredMcD said

Access denied (error 403)

Yup. Just click on the Test forum menu item anyway and all should be good.

more options

Thanks for confirming my problem FredMcD. I also opened a ticket with the service used to host the cvmg.ca site. They say they are investigating and it is likely their problem.