X
Tap here to go to the mobile version of the site.

Support Forum

Upgrade nagging pain

Posted

I've fiddled all the about:config upgrade settings I can find, still my firefox nags every day to up upgrade. Unless I can stop the nag I will change browser. I *never* want to upgrade. Reason: macx have a bizare DNS and at the slightest whim MyDNS is replaced with TheirDNS Every release of firefox seems to 'enhance' using the URL bar to search. Everytime mac's DNS goes haywire I go to eg sandypit.home and get a Google search for 'sandypit.home'.

Why on earth URL bar is used to search on a desktop machine is bizare. I find no about:config setting that says "search with url bar TRUE/FALSE"
I've fiddled all the about:config upgrade settings I can find, still my firefox nags every day to up upgrade. Unless I can stop the nag I will change browser. I *never* want to upgrade. Reason: macx have a bizare DNS and at the slightest whim MyDNS is replaced with TheirDNS Every release of firefox seems to 'enhance' using the URL bar to search. Everytime mac's DNS goes haywire I go to eg sandypit.home and get a Google search for 'sandypit.home'. Why on earth URL bar is used to search on a desktop machine is bizare. I find no about:config setting that says "search with url bar TRUE/FALSE"

Chosen solution

Firstly, it's never recommended to run old versions of Firefox because it can leave you vulnerable to security and privacy issues that have been patched in newer versions of Firefox.

However, if you have your heart set on keeping your older version of Firefox and disabling updates, you can do so by configuring a policies.json file on Firefox. This is intended primarily for enterprise environments, but it works for the regular version of Firefox as well.

Your policies.json file should contain the following code:

{

 "policies": {
   "DisableAppUpdate": true
 }

}

However, I'd recommend simply disabling Google searching from the Firefox address bar because this sounds more like it would fix your issue. To do so, just do the following:

  1. Type about:config in your Firefox address bar
  2. Bypass the security warning
  3. Find keyword.enabled
  4. Double click it to change the value to false

Then you can customize your Firefox toolbar to add the search bar if you wish.

Hope this helps.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:62.0) Gecko/20100101 Firefox/62.0

More Information

Wesley Branton
  • Top 10 Contributor
577 solutions 4931 answers

Chosen Solution

Firstly, it's never recommended to run old versions of Firefox because it can leave you vulnerable to security and privacy issues that have been patched in newer versions of Firefox.

However, if you have your heart set on keeping your older version of Firefox and disabling updates, you can do so by configuring a policies.json file on Firefox. This is intended primarily for enterprise environments, but it works for the regular version of Firefox as well.

Your policies.json file should contain the following code:

{

 "policies": {
   "DisableAppUpdate": true
 }

}

However, I'd recommend simply disabling Google searching from the Firefox address bar because this sounds more like it would fix your issue. To do so, just do the following:

  1. Type about:config in your Firefox address bar
  2. Bypass the security warning
  3. Find keyword.enabled
  4. Double click it to change the value to false

Then you can customize your Firefox toolbar to add the search bar if you wish.

Hope this helps.

Firstly, it's never recommended to run old versions of Firefox because it can leave you vulnerable to security and privacy issues that have been patched in newer versions of Firefox. However, if you have your heart set on keeping your older version of Firefox and disabling updates, you can do so by [[Customizing Firefox Using policies.json|configuring a policies.json file on Firefox]]. This is intended primarily for enterprise environments, but it works for the regular version of Firefox as well. Your policies.json file should contain the following code: <code>{ "policies": { "DisableAppUpdate": true } }</code> However, I'd recommend simply disabling Google searching from the Firefox address bar because this sounds more like it would fix your issue. To do so, just do the following: # Type <code>about:config</code> in your Firefox address bar # Bypass the security warning # Find <code>keyword.enabled</code> # Double click it to change the value to <code>false</code> Then you can [[Customize Firefox controls, buttons and toolbars|customize your Firefox toolbar to add the search bar]] if you wish. Hope this helps.

Question owner

Except that about:config entries are poorly documented and I did search but would not guess keyword.enabled. Thanks lots.

Except that about:config entries are poorly documented and I did search but would not guess keyword.enabled. Thanks lots.
Wesley Branton
  • Top 10 Contributor
577 solutions 4931 answers

Yeah. Unfortunately, because there are so many entries, there's not really any spectacular or complete documentation of these entries at this time. Sorry.

But glad that I was able to provide you with the preference that you were looking for.

Yeah. Unfortunately, because there are so many entries, there's not really any spectacular or complete documentation of these entries at this time. Sorry. But glad that I was able to provide you with the preference that you were looking for.