X
Tap here to go to the mobile version of the site.

Support Forum

What Happened?

Posted

I have been using Firefox since last year without an issue until last night when it decided I did not need internet access any longer. I went to my normal Top Site pick, ask.com which I have used without issue for years. I do not have nor do I want google, I do not trust them. Anyway, I went to use my Top Site choice & received an error page that said.... your connection is not secure (SEC__ERROR__UNKNOWN__ISSUER) As I said, I have used ask.com for years. When I attempted to open a different site, same thing. I have been unable to get online since last night & have had to use my phone to contact this site. Does Firefox have actual support people users can contact for help? I guess I might just have to uninstall Firefox & find another browser.... Why did this happen & how do I fix it? Thanks for any help anyone can provide can provide. Oh, I have AVG, CCleaner & Malwarebytes Premium, all of which I have had since before I installed Firefox.

I have been using Firefox since last year without an issue until last night when it decided I did not need internet access any longer. I went to my normal Top Site pick, ask.com which I have used without issue for years. I do not have nor do I want google, I do not trust them. Anyway, I went to use my Top Site choice & received an error page that said.... your connection is not secure (SEC__ERROR__UNKNOWN__ISSUER) As I said, I have used ask.com for years. When I attempted to open a different site, same thing. I have been unable to get online since last night & have had to use my phone to contact this site. Does Firefox have actual support people users can contact for help? I guess I might just have to uninstall Firefox & find another browser.... Why did this happen & how do I fix it? Thanks for any help anyone can provide can provide. Oh, I have AVG, CCleaner & Malwarebytes Premium, all of which I have had since before I installed Firefox.
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (iPhone; CPU iPhone OS 12_1_2 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/12.0 Mobile/15E148 Safari/604.1

More Information

Seburo
  • Top 25 Contributor
  • Moderator
618 solutions 4471 answers

Hi

Thank you for your question.

Is this an issue with Firefox for Android, or are you using Firefox on a desktop or laptop computer?

Hi Thank you for your question. Is this an issue with Firefox for Android, or are you using Firefox on a desktop or laptop computer?
Was this helpful to you?
Quote

Question owner

It is Firefox on my desktop, but I figured out what the problem was. Even though no one else uses my computer & I do not go into settings unless an issue arises, one of the boxes got checked. By who & how I have no clue. After trying some of the suggestions in the Mozilla community & not having any luck I went to options, then Privacy & Security. I scrolled through until I found Certificates at the bottom of the page. There were three selections.... Select one automatically/Ask you every time/Query OCSP responder servers to confirm the current validity of certificates. The ask you every time box was checked & so was the Query OCSP box. I believe there was a Firefox update on 1/18/19 (no quite sure) & then a couple of days later every site I tried gave me the same Your connection is not secure. Since the Ask me box was marker with a blue dot & the Query box had a check mark, I unchecked the Query box & restarted the computer. Now everything is fine. I just can't figure out how that Query box could have gotten checked & why?

It is Firefox on my desktop, but I figured out what the problem was. Even though no one else uses my computer & I do not go into settings unless an issue arises, one of the boxes got checked. By who & how I have no clue. After trying some of the suggestions in the Mozilla community & not having any luck I went to options, then Privacy & Security. I scrolled through until I found Certificates at the bottom of the page. There were three selections.... Select one automatically/Ask you every time/Query OCSP responder servers to confirm the current validity of certificates. The ask you every time box was checked & so was the Query OCSP box. I believe there was a Firefox update on 1/18/19 (no quite sure) & then a couple of days later every site I tried gave me the same Your connection is not secure. Since the Ask me box was marker with a blue dot & the Query box had a check mark, I unchecked the Query box & restarted the computer. Now everything is fine. I just can't figure out how that Query box could have gotten checked & why?
Was this helpful to you?
Quote
Seburo
  • Top 25 Contributor
  • Moderator
618 solutions 4471 answers

Helpful Reply

Glad to hear it.

The only thing I can think of is that you may have been asked a question or installed some other software that could have changed this setting.

Glad to hear it. The only thing I can think of is that you may have been asked a question or installed some other software that could have changed this setting.
Was this helpful to you? 1
Quote

Question owner

That's a possibility. Thank You for replying to my problem, I appreciate it.

That's a possibility. Thank You for replying to my problem, I appreciate it.
Was this helpful to you?
Quote
Seburo
  • Top 25 Contributor
  • Moderator
618 solutions 4471 answers

Hello,

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.

Hello, I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily. Thank you for contacting Mozilla Support.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.