Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Youtube automatically loads a random community page and constantly refreshes

  • 4 replies
  • 3 have this problem
  • 3412 views
  • Last reply by Kruks

more options

It doesn't seem to matter if I click my YT bookmark or type in the URL. YT is the only site to have this issue but works fine with other browsers.

Modified by Kruks

Chosen solution

An extension named YouTube High Definition has been linked to this problem:

https://old.reddit.com/r/firefox/comments/aesm24/youtube_redirecting_to_a_channel/

You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions.

Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Try removing YouTube High Definition, and anything you do not remember installing or why.

Any improvement (test YouTube in a new tab)?

Read this answer in context 👍 1

All Replies (4)

more options

It loads based on your History and what you watched. So what does your link look like for YT? And are those other browser login or just no login and is firefox login or not? That also makes a difference.

Modified by WestEnd

more options

Chosen Solution

An extension named YouTube High Definition has been linked to this problem:

https://old.reddit.com/r/firefox/comments/aesm24/youtube_redirecting_to_a_channel/

You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions.

Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Try removing YouTube High Definition, and anything you do not remember installing or why.

Any improvement (test YouTube in a new tab)?

more options

https://www.youtube.com/channel/UC2t5bjwHdUX4vM2g8TRDq5g/community?lb=UgyylR2T6Np_9T6goUx4AaABCQ

I'm logged in on the other browsers to YT Weird part is that I'm not clicking anything once on the YT home screen, it automatically redirects me

more options

jscher2000 said

An extension named YouTube High Definition has been linked to this problem: https://old.reddit.com/r/firefox/comments/aesm24/youtube_redirecting_to_a_channel/ You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:
  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return
In the left column of the Add-ons page, click Extensions. Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Try removing YouTube High Definition, and anything you do not remember installing or why. Any improvement (test YouTube in a new tab)?

This was it, thank you!