X
Tap here to go to the mobile version of the site.

Support Forum

How do I enable Windows 10 Pro to allow notifications for Firefox?

Posted

This seems to be an issue with Windows (running 10 Pro) on my laptop, but I'm hoping someone can help. In Windows notification settings, I can select some programs/apps, for which Windows will allow notifications (see screenshot). Firefox is not listed among these, although Opera is. I've been hoping that one of the recent Firefox updates would fix this, but that hasn't happened. I do have notifications enable in Firefox, but those notifications aren't getting through to Windows.

Anyone know how to solve this? Thanks!

This seems to be an issue with Windows (running 10 Pro) on my laptop, but I'm hoping someone can help. In Windows notification settings, I can select some programs/apps, for which Windows will allow notifications (see screenshot). Firefox is not listed among these, although Opera is. I've been hoping that one of the recent Firefox updates would fix this, but that hasn't happened. I do have notifications enable in Firefox, but those notifications aren't getting through to Windows. Anyone know how to solve this? Thanks!
Attached screenshots

Chosen solution

Maybe you need to get a notification at least once in order to approve it? You could try this test page:

https://developer.mozilla.org/en-US/docs/Web/API/Notifications_API/Using_the_Notifications_API#Replacing_existing_notifications

A message should drop from the left end of the address bar to allow the page to send notifications. Then if you scroll down past the shaded code box, there's a demo button.

Read this answer in context 1
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0

More Information

WestEnd
  • Top 10 Contributor
59 solutions 5045 answers

For that to work it must show up in the notification for Windows in the screenshot you provided. And looking at mine I don't see that listed as part of those notifications.

For that to work it must show up in the notification for Windows in the screenshot you provided. And looking at mine I don't see that listed as part of those notifications.
Was this helpful to you? 0
Quote
jscher2000
  • Top 10 Contributor
8198 solutions 67055 answers

Chosen Solution

Maybe you need to get a notification at least once in order to approve it? You could try this test page:

https://developer.mozilla.org/en-US/docs/Web/API/Notifications_API/Using_the_Notifications_API#Replacing_existing_notifications

A message should drop from the left end of the address bar to allow the page to send notifications. Then if you scroll down past the shaded code box, there's a demo button.

Maybe you need to get a notification at least once in order to approve it? You could try this test page: https://developer.mozilla.org/en-US/docs/Web/API/Notifications_API/Using_the_Notifications_API#Replacing_existing_notifications A message should drop from the left end of the address bar to allow the page to send notifications. Then if you scroll down past the shaded code box, there's a demo button.
Was this helpful to you? 1
Quote

Question owner

jscher2000, thanks that worked, mostly. A notification pops up, but there's no sound, and I can't find a way to turn on audio for notifications. Is that possible? Thanks again!

jscher2000, thanks that worked, mostly. A notification pops up, but there's no sound, and I can't find a way to turn on audio for notifications. Is that possible? Thanks again!
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8198 solutions 67055 answers

Hmm, I don't know if you can have audio with notifications. Sites can generate audio in other ways, so they might have to do both independently.

Hmm, I don't know if you can have audio with notifications. Sites can generate audio in other ways, so they might have to do both independently.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.