Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

having problems with updating. You tell me that you have sent me an email (three times) but I haven't had them

more options

problem is as in Question. I haven't used FF in a while so had this email from you: New sign-in to Firefox For added security, please confirm this sign-in from the following device:

But I kept being told my Username/Password were wrong so I clicked on Forgot password, then Forgot Username and both times there was an on-screen message "email has been sent" but I didn't receive it. SOS please!! Thanks

Chosen solution

Can you not add accounts.firefox.com to your Safe Senders list?

Read this answer in context 👍 0

All Replies (6)

more options

Are you sure that you verified that the register email was the same one you ask to send the email to?

more options

WestEnd said

Are you sure that you verified that the register email was the same one you ask to send the email to?

Definitely!

more options

Hi, sorry to hear you are having a problem; please see if anything here helps - I'm having problems confirming my Firefox Account.

If your question is resolved by this or another answer, please help other users by marking the best reply as Solved. Thank you!

more options

Hello Scribe & thanks for your help. My problem appears to be that to add someone to my Safe Senders list, I have to click on an email from the sender and proceed from there. But I haven't actually received any emails!

Nor can I find any other route via the FF website

more options

Chosen Solution

Can you not add accounts.firefox.com to your Safe Senders list?

more options

TaffyOutlane said

problem is as in Question. I haven't used FF in a while so had this email from you: New sign-in to Firefox For added security, please confirm this sign-in from the following device: But I kept being told my Username/Password were wrong so I clicked on Forgot password, then Forgot Username and both times there was an on-screen message "email has been sent" but I didn't receive it. SOS please!! Thanks

got there in the end. Thanks