X
Tap here to go to the mobile version of the site.

Safely share files online with encrypted links that “self-destruct.” Try Firefox Send.

Give hackers a swift kick in the cookies. See if your data has been affected by a breach with Firefox Monitor. Try it now.

Access your history, passwords and open tabs wherever you are with Sync. Connect a second device.

Support Forum

Firefox is now trying to download videos embedded on websites rather than playing them. I have unistalled, cleared all files and reinstalled, but with no succes

Posted

No issues previously, however this just started. If I go to a website with embedded video Firefox tries to download the video rather than playing the content. I have been on the help pages, have uninstalled Firefox, cleared out all old files and reinstalled. I have done this twice but it has not cured the problem. It may be something in settings, but if it is I can't find it. Any help appreciated, thanks.

No issues previously, however this just started. If I go to a website with embedded video Firefox tries to download the video rather than playing the content. I have been on the help pages, have uninstalled Firefox, cleared out all old files and reinstalled. I have done this twice but it has not cured the problem. It may be something in settings, but if it is I can't find it. Any help appreciated, thanks.
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:64.0) Gecko/20100101 Firefox/64.0

More Information

jscher2000
  • Top 10 Contributor
8089 solutions 66095 answers

Does this affect typical video sites like YouTube and Vimeo, or do you mean sites that have embedded videos from YouTube or Vimeo? Or other sites (in that case, please give examples)?

Does this affect typical video sites like YouTube and Vimeo, or do you mean sites that have embedded videos from YouTube or Vimeo? Or other sites (in that case, please give examples)?
Was this helpful to you?
Quote

Question owner

Hi jscher, thanks for your reply. Having checked it would seem it only happens with sites with mp4 videos, youtube appears to work ok. I had read on here that another user had the same issue and solved it with removing and re-installing, but that doesn't work for me. I recently added a codec pack, (Shark007), so will try removing that and see if anything changes.

Removed codec pack, issue still persists. I don't get the issue with internet explorer, just firefox.

Hi jscher, thanks for your reply. Having checked it would seem it only happens with sites with mp4 videos, youtube appears to work ok. I had read on here that another user had the same issue and solved it with removing and re-installing, but that doesn't work for me. I recently added a codec pack, (Shark007), so will try removing that and see if anything changes. Removed codec pack, issue still persists. I don't get the issue with internet explorer, just firefox.
Was this helpful to you?
Quote
sppeerless 0 solutions 1 answers

Try to remove any other newly added add on. Check the settings of firefox where it decide what has to do with video playback when website is opened.!

Try to remove any other newly added add on. Check the settings of firefox where it decide what has to do with video playback when website is opened.!
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8089 solutions 66095 answers

Hi Woody420, thank you for the additional info.

Do you get blue checkmarks for at least the first five boxes on this test page:

https://www.youtube.com/html5

Do you use any add-ons related to videos? As a quick test to rule out an add-on issue, you could try the same sites in Firefox's Safe Mode. In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Hi Woody420, thank you for the additional info. Do you get blue checkmarks for at least the first five boxes on this test page: https://www.youtube.com/html5 Do you use any add-ons related to videos? As a quick test to rule out an add-on issue, you could try the same sites in Firefox's Safe Mode. In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled * (menu bar) Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement?
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.