X
Tap here to go to the mobile version of the site.

Support Forum

Why suddenly can I no longer log into my bank website from Firefx, tho I can from google chrome using same id and password -- bank says Firefox is the problem?

Posted

Dear Sirs,

Suddenly, I can no longer log into my bank account's website from Firefox. I get the website but it does not let me log in. Password and ID are unchanged and they are not saved in Firefox. I have to put them in each time. I have called the bank and they say the problem is Firefox. They asked me to use Google chrome instead as a browser and that works-- ie I call up the bank website, put in the id and password and get into my account in the normal way. Thus, bottom line, Google Chrome works for me to get to my bank but Firefox does not. Why? Can this be fixed? I am concerned that if suddenly Firefox cannot get me my bank, what am I going to lose next?

I have tried, unsuccessfully to email Firefox directly on this. If anyone knows how to fix this or at least how to get my question to Firefox, I would be most appreciative.

Thanks,

Fred Coleman

Dear Sirs, Suddenly, I can no longer log into my bank account's website from Firefox. I get the website but it does not let me log in. Password and ID are unchanged and they are not saved in Firefox. I have to put them in each time. I have called the bank and they say the problem is Firefox. They asked me to use Google chrome instead as a browser and that works-- ie I call up the bank website, put in the id and password and get into my account in the normal way. Thus, bottom line, Google Chrome works for me to get to my bank but Firefox does not. Why? Can this be fixed? I am concerned that if suddenly Firefox cannot get me my bank, what am I going to lose next? I have tried, unsuccessfully to email Firefox directly on this. If anyone knows how to fix this or at least how to get my question to Firefox, I would be most appreciative. Thanks, Fred Coleman

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:64.0) Gecko/20100101 Firefox/64.0

More Information

Scribe 725 solutions 3456 answers

Hi, try: 3-bar menu > Options/Preferences > Privacy & Security, then under Content Blocking, remove all blocks; also under Permissions, deselect any block on Pop-up windows.

Under Cookies and Site Data, make sure that cookies are enabled.

Now reload the site.

If that works, should you wish, you can make an exception for the site.


If the above doesn't work, hold down the Option key when you start Firefox to start in Safe Mode. More - Troubleshoot Firefox issues using Safe Mode.

If it works in Safe Mode, disable any theme or extensions you have - 3-bar menu > Add-ons > Themes/Extensions and restart Firefox; then if it's OK, re-enable them one by one until you find the culprit. You may need to restart Firefox after enabling some extensions.

If your question is resolved by this or another answer, please help other users by marking the best reply as Solved. Thank you!

Hi, try: 3-bar menu > Options/Preferences > Privacy & Security, then under Content Blocking, remove all blocks; also under Permissions, deselect any block on Pop-up windows. Under Cookies and Site Data, make sure that cookies are enabled. Now reload the site. If that works, should you wish, you can make an exception for the site. -------------------------------------- If the above doesn't work, hold down the Option key when you start Firefox to start in Safe Mode. More - [[Troubleshoot Firefox issues using Safe Mode]]. If it works in Safe Mode, disable any theme or extensions you have - 3-bar menu > Add-ons > Themes/Extensions and restart Firefox; then if it's OK, re-enable them one by one until you find the culprit. You may need to restart Firefox after enabling some extensions. ''If your question is resolved by this or another answer, please help other users by marking the best reply as Solved. Thank you!''