X
Tap here to go to the mobile version of the site.

Support Forum

Your connection is not secure. Error code: MOZILLA_PKIX_ERROR_SELF_SIGNED_CERT

Posted

I am a Web developer. I have a localhost XAMPP installation which is not accessible through the Internet. I use the self-signed certificate supplied with XAMPP to enable SSL development. Let me repeat myself — I am doing my development on my own localhost with no access over the internet for my development server. This is my own machine, completely and entirely owned by me. Every time Firefox does an update, it finds a new way to tell me that it has complete control over the machine that it allows me to use only on its own terms. It does everything it can to ensure that I have no control over it.

In light of this, several years ago, I completely uninstalled Firefox, only too happy to consign it to the evil waste heap it so richly deserves. Like a complete idiot I decided to reinstall it about six months ago. Since then, I've spent weeks trying to make it work. Just when I get it somehow to work, it begins to completely bomb again. This last iteration, just one in a long series of iterations, I have spent two complete, entire, and utterly wasted DAYS trying to find a resolution to no avail. That's two days, well over 16 hours, of completely wasted time when I could have been earning money. (When is Firefox going to pay me for what that cost? Where and how do I submit my bill?) It still does not work continuing to give a Your connection is not secure. Error code: MOZILLA_PKIX_ERROR_SELF_SIGNED_CERT error and no alternatives for a workaround. It should be noted that, at no point, does Firefox give me the "Add Exception" button that it formerly gave. (I guess they had to remove that workaround because it prevented Firefox from having absolute control over my machine.

During those two, long, unproductive days, I tried every supposed resolution I could find via Google, including numerous changes to about:config. None of them worked.

The machine that my localhost is installed on is a Windos 10 Pro machine running Apache 2.4. I am using Firefox v.63 with the Flash plugin (not used in web development, of course). My anti-malware is Malwarebytes. When Firefox, the greatest malware of all times, decided to take control of my machine and block my web development, I completely turned off Malwarebytes to ensure that it wasn't the primary culprit. (It had never been at the root of the problem in the past. Malwarebytes makes it easy to add exceptions for an IP address such as 127.0.0.1, the IP universally used by localhosts. In any case, turning off Malwarebytes, of course, did nothing with regard to the issue created by Firefox. Naturally, Firefox would never implement such a simple resolution because, after all, they have to have complete control over my machine.)

My question is: Is there any way to permanently, totally, completely, and irrevocably prevent Firefox from blockading me from doing web development, allowing me to access with ease, localhost web sites, created in the Apache virtual host (httpd-vhost.conf) configuration file on IP 127.0.0.1 and established in the Windows hosts file (/Windows/System32/drivers/etc/hosts)? Or is the only resolution to completely uninstall/trash Firefox from my system and never look back?

Needless to say, I am frustrated beyond belief.

I am a Web developer. I have a localhost XAMPP installation which is not accessible through the Internet. I use the self-signed certificate supplied with XAMPP to enable SSL development. Let me repeat myself — I am doing my development on my own localhost with no access over the internet for my development server. This is my own machine, completely and entirely owned by me. Every time Firefox does an update, it finds a new way to tell me that it has complete control over the machine that it allows me to use only on its own terms. It does everything it can to ensure that I have no control over it. In light of this, several years ago, I completely uninstalled Firefox, only too happy to consign it to the evil waste heap it so richly deserves. Like a complete idiot I decided to reinstall it about six months ago. Since then, I've spent weeks trying to make it work. Just when I get it somehow to work, it begins to completely bomb again. This last iteration, just one in a long series of iterations, I have spent two complete, entire, and utterly wasted DAYS trying to find a resolution to no avail. That's two days, well over 16 hours, of completely wasted time when I could have been earning money. (When is Firefox going to pay me for what that cost? Where and how do I submit my bill?) It still does not work continuing to give a Your connection is not secure. Error code: MOZILLA_PKIX_ERROR_SELF_SIGNED_CERT error and no alternatives for a workaround. It should be noted that, at no point, does Firefox give me the "Add Exception" button that it formerly gave. (I guess they had to remove that workaround because it prevented Firefox from having absolute control over my machine. During those two, long, unproductive days, I tried every supposed resolution I could find via Google, including numerous changes to about:config. None of them worked. The machine that my localhost is installed on is a Windos 10 Pro machine running Apache 2.4. I am using Firefox v.63 with the Flash plugin (not used in web development, of course). My anti-malware is Malwarebytes. When Firefox, the greatest malware of all times, decided to take control of my machine and block my web development, I completely turned off Malwarebytes to ensure that it wasn't the primary culprit. (It had never been at the root of the problem in the past. Malwarebytes makes it easy to add exceptions for an IP address such as 127.0.0.1, the IP universally used by localhosts. In any case, turning off Malwarebytes, of course, did nothing with regard to the issue created by Firefox. Naturally, Firefox would never implement such a simple resolution because, after all, they have to have complete control over my machine.) My question is: Is there any way to permanently, totally, completely, and irrevocably prevent Firefox from blockading me from doing web development, allowing me to access with ease, localhost web sites, created in the Apache virtual host (httpd-vhost.conf) configuration file on IP 127.0.0.1 and established in the Windows hosts file (/Windows/System32/drivers/etc/hosts)? Or is the only resolution to completely uninstall/trash Firefox from my system and never look back? Needless to say, I am frustrated beyond belief.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0

More Information

jscher2000
  • Top 10 Contributor
8637 solutions 70648 answers

Hi LarryTX, I'm surprised there's no button to add an exception after you open the Advanced section. We are used to seeing that on test pages such as:

https://self-signed.badssl.com/

Does the error page you get mention any reason that it won't allow an exception, such as Strict Transport Security (HSTS) being required?

There have been discussions in other threads or on other forums about the flag indicating that the certificate is a certificate authority, and/or the SAN (Subject Alternative Name) field in the certificate, being important to Firefox and possibly missing or not accepted in some self-signed certificates. I haven't searched up those threads.

Hi LarryTX, I'm surprised there's no button to add an exception after you open the Advanced section. We are used to seeing that on test pages such as: https://self-signed.badssl.com/ Does the error page you get mention any reason that it won't allow an exception, such as Strict Transport Security (HSTS) being required? There have been discussions in other threads or on other forums about the flag indicating that the certificate is a certificate authority, and/or the SAN (Subject Alternative Name) field in the certificate, being important to Firefox and possibly missing or not accepted in some self-signed certificates. I haven't searched up those threads.