X
Tap here to go to the mobile version of the site.

Support Forum

Firefox 64.0 completely paralysed on Win7

Posted

Firefox user of old but got sucked into using Chrome for a year or so. Trying to correct my ways and have installed Firefox on Win 7. Installed OK and starts/loads, but will not open any pages, external or internal html files. Tried safe mode, tried hardware acceleration tip, etc but nothing has changed the unresponsiveness. Really don't want to give up and turn my back, but there is only so much time....

Firefox user of old but got sucked into using Chrome for a year or so. Trying to correct my ways and have installed Firefox on Win 7. Installed OK and starts/loads, but will not open any pages, external or internal html files. Tried safe mode, tried hardware acceleration tip, etc but nothing has changed the unresponsiveness. Really don't want to give up and turn my back, but there is only so much time....

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/71.0.3578.98 Safari/537.36

More Information

FredMcD
  • Top 10 Contributor
4229 solutions 59022 answers

Some problems occur when your Internet security program was set to trust the previous version of Firefox, but no longer recognizes your updated version as trusted. Now how to fix the problem: To allow Firefox to connect to the Internet again;

  • Make sure your Internet security software is up-to-date (i.e. you are running the latest version).
  • Remove Firefox from your program's list of trusted or recognized programs. For detailed instructions, see

Configure firewalls so that Firefox can access the Internet. {web link}

Some problems occur when your Internet security program was set to trust the previous version of Firefox, but no longer recognizes your updated version as trusted. Now how to fix the problem: To allow Firefox to connect to the Internet again; * Make sure your Internet security software is up-to-date (i.e. you are running the latest version). * Remove Firefox from your program's list of trusted or recognized programs. For detailed instructions, see '''[https://support.mozilla.org/en-US/kb/configure-firewalls-so-firefox-can-access-internet Configure firewalls so that Firefox can access the Internet.]''' {web link}

Question owner

Thanks for trying to help. I've been through the Firewall checking process and confirmed it's only the Windows Firewall running, and then tried removing and adding back Firefox, but that still hasn't sorted it. I then tried disabling the Firewall and running Firefox, but that made no difference either - so unless that should really have had a reboot after disabling which I didn't do, it appears it isn't a Firewall related problem. There were Registry issues which I tidied up with CCLeaner, but it's not sorted Firefox. Thanks again for trying

Thanks for trying to help. I've been through the Firewall checking process and confirmed it's only the Windows Firewall running, and then tried removing and adding back Firefox, but that still hasn't sorted it. I then tried disabling the Firewall and running Firefox, but that made no difference either - so unless that should really have had a reboot after disabling which I didn't do, it appears it isn't a Firewall related problem. There were Registry issues which I tidied up with CCLeaner, but it's not sorted Firefox. Thanks again for trying
FredMcD
  • Top 10 Contributor
4229 solutions 59022 answers

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select Network.

[56+] Type about:preferences#general<enter> in the address bar. Look for Network. +++++++++++++++++++++ Look for Configure How Firefox Connects and press the Settings button. If you are using a proxy, make sure those settings are correct. If there is no proxy, first try No Proxy. If there is a problem, then try System Proxy.

Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced, ''' Select '''Network. ''' [56+] Type '''about:preferences#general'''<enter> in the address bar. Look for '''Network. ''' +++++++++++++++++++++ Look for '''Configure How Firefox Connects''' and press the '''Settings''' button. If you are using a proxy, make sure those settings are correct. If there is no proxy, first try '''No Proxy. ''' If there is a problem, then try '''System Proxy. '''

Question owner

When I type about:preferences#advanced <Enter> from the Address bar within a Firefox window, then there is no response from the browser. The New tab stays white, with the little left to right animation going back and forward - same as for trying to open an internal or external link. So I dug into the settings from 'Options' (and then can see the about:preferences etc page addresses in the address bar). Switched around between System Proxy, No Proxy Auto-detect Proxy settings, but still no change in behaviour. cheers

When I type about:preferences#advanced <Enter> from the Address bar within a Firefox window, then there is no response from the browser. The New tab stays white, with the little left to right animation going back and forward - same as for trying to open an internal or external link. So I dug into the settings from 'Options' (and then can see the about:preferences etc page addresses in the address bar). Switched around between System Proxy, No Proxy Auto-detect Proxy settings, but still no change in behaviour. cheers
FredMcD
  • Top 10 Contributor
4229 solutions 59022 answers

Let’s do a full clean re-install;

Download Firefox For All languages And Systems {web link}

Save the file. Then Close Firefox.

Using your file browser, open the Programs Folder on your computer.

Windows: C:\Program Files C:\Program Files (x86) Note: Check Both Folders

Mac: Open the "Applications" folder. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac

Linux: Check your user manual. If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it. See Install Firefox on Linux; https://support.mozilla.org/en-US/kb/install-firefox-linux

If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory. http://www.mozilla.org/firefox#desktop ++++++++++++++++++++++++++++ Look for, and remove any Mozilla or Firefox program folders. Do not remove the Mozilla Thunderbird folder if there is one.

Do Not remove any profile folders.

After rebooting the computer, run a registry scanner if you have one. Then run the installer. +++++++++++++++++++++++++++ If there is a problem, start your Computer in safe mode and try again.

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode This shows how to Start all Computers in Safe Mode; Free Online Encyclopedia

Let’s do a full clean re-install; [http://www.mozilla.org/en-US/firefox/all/ Download Firefox For All languages And Systems] {web link} Save the file. Then '''Close Firefox. ''' Using your file browser, open the '''Programs Folder''' on your computer. '''Windows: ''' C:\Program Files C:\Program Files (x86) '''Note:''' Check Both Folders '''Mac: ''' Open the ''' "Applications" ''' folder. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac '''Linux: ''' Check your user manual. If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it. See Install Firefox on Linux; https://support.mozilla.org/en-US/kb/install-firefox-linux If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory. http://www.mozilla.org/firefox#desktop ++++++++++++++++++++++++++++ Look for, and remove any '''Mozilla''' or '''Firefox''' program folders. Do not remove the '''Mozilla Thunderbird''' folder if there is one. '''Do Not''' remove any profile folders. After rebooting the computer, run a registry scanner if you have one. Then run the installer. +++++++++++++++++++++++++++ If there is a problem, start your '''Computer''' in safe mode and try again. http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode This shows how to Start all Computers in Safe Mode; Free Online Encyclopedia

Question owner

Thanks for post. Did all that, but behaviour unchanged - it simply does not respond to the 'Enter' key by opening a page internal or external. I managed to screw up some dlls connected with Office 2016 installs probably as part of registry cleaning and had to do a full reinstall. So that's it, I don't usually give up, but times up on Firefox on Windows 7 for me. Sorry folks.

Thanks for post. Did all that, but behaviour unchanged - it simply does not respond to the 'Enter' key by opening a page internal or external. I managed to screw up some dlls connected with Office 2016 installs probably as part of registry cleaning and had to do a full reinstall. So that's it, I don't usually give up, but times up on Firefox on Windows 7 for me. Sorry folks.
WestEnd
  • Top 25 Contributor
60 solutions 5377 answers

I have IE, Edge, Chrome, FF installed and have no issues with multiple browsers on the same system. What goes is if you installed or upgraded ff what you want to do is backup boomarks and then uninstall all ff and deleting mozilla folder and then reinstall a new version of ff to see if the problem wasn't bad or corrupted upgrade.

I have IE, Edge, Chrome, FF installed and have no issues with multiple browsers on the same system. What goes is if you installed or upgraded ff what you want to do is backup boomarks and then uninstall all ff and deleting mozilla folder and then reinstall a new version of ff to see if the problem wasn't bad or corrupted upgrade.