Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Bookmarks are different on my Windows 7 and Windows 10, why

  • 5 replies
  • 1 has this problem
  • 24 views
  • Last reply by cjbill

more options

Bought a new Windows 10 computer and installed Firefox but I don't like the way bookmarks and passwords are handled. Both computers have Firefox Quantum 64.0 64 bit but they are different. On my Windows 10 the bookmarks for files with passwords required do not show up in my bookmarks list and I have to look for saved passwords to find them . Also Firefox asks for my master password when it starts up rather than when I access a password site. I like the old way why are they different?

Bought a new Windows 10 computer and installed Firefox but I don't like the way bookmarks and passwords are handled. Both computers have Firefox Quantum 64.0 64 bit but they are different. On my Windows 10 the bookmarks for files with passwords required do not show up in my bookmarks list and I have to look for saved passwords to find them . Also Firefox asks for my master password when it starts up rather than when I access a password site. I like the old way why are they different?

Chosen solution

You can add the "Bookmarks Menu" button that shows the bookmarks in a drop-down list to the Navigation Toolbar via these steps:

  • click the bookshelf 57 library icon icon on the Navigation Toolbar or alternatively use the Library menu in the "3-bar" Firefox menu button New Fx Menu drop-down list
  • click Bookmarks
  • click "Bookmarking Tools", then click "Add Bookmarks Menu to Toolbar"
The Bookmark Menu button Bookmark Menu icon (star on tray) should appear on the Navigation Toolbar.

You can also drag the Bookmarks Menu button from the Customize palette to the Navigation Toolbar

See also "How do I add the Bookmarks Menu button to the toolbar?":

Read this answer in context 👍 0

All Replies (5)

more options

OK, OK I found I saved my passwords but didn't "bookmark" the page. I still don't understand why I have to enter my master password when Firefox starts. That leaves all protected sites open!

more options

Hi cjbill, did you set up Firefox Sync on your new Firefox? Firefox Sync will try to connect shortly after you start Firefox, and if you saved your Firefox Account password and have a Master Password, then your MP will be needed.

Assuming you don't really need to start sync-ing at that moment, you can cancel the dialog and enter your MP later when needed.

Or you can disconnect your Firefox from Sync.

Do either of those seem to work?

more options

Hi jscher, I did turn off sync and it still asks for my master password when it starts up. I have found I can cancel that request and everything is OK until I go to a page that requires a password and then I have to enter it. After that I no longer have to enter the master password to get on other sites which I tested and found to be the same on my windows 7 version. So I guess I am OK with that but have remember to close Firefox if I leave the computer. I'm still puzzled why there are differences between the two computers like how bookmarks are shown when you click on "bookmarks" but it's not critical. Thanks again for your suggestions.

more options

Chosen Solution

You can add the "Bookmarks Menu" button that shows the bookmarks in a drop-down list to the Navigation Toolbar via these steps:

  • click the bookshelf 57 library icon icon on the Navigation Toolbar or alternatively use the Library menu in the "3-bar" Firefox menu button New Fx Menu drop-down list
  • click Bookmarks
  • click "Bookmarking Tools", then click "Add Bookmarks Menu to Toolbar"
The Bookmark Menu button Bookmark Menu icon (star on tray) should appear on the Navigation Toolbar.

You can also drag the Bookmarks Menu button from the Customize palette to the Navigation Toolbar

See also "How do I add the Bookmarks Menu button to the toolbar?":

more options

Thanks, I appreciate the support. Still getting used to Windows 10.