X
Tap here to go to the mobile version of the site.

Support Forum

Firefox v64 (64-bit) not displaying Flash content

Posted

Flash Player 32.0.0.101 Firefox v64 (64-bit) Windows 10

With this configuration Flash content does not work.

On Windows 7 Enterprise, the same version of Flash Player and Firefox

It looks like it is trying to load under Windows 10 but ultimately what is displayed is a blank screen.

Is anyone else running Windows 10 with Firefox and Flash Player and getting it to work. I cannot post the URL because the application is a inhouse application and requires logging in.

Flash Player 32.0.0.101 Firefox v64 (64-bit) Windows 10 With this configuration Flash content does not work. On Windows 7 Enterprise, the same version of Flash Player and Firefox It looks like it is trying to load under Windows 10 but ultimately what is displayed is a blank screen. Is anyone else running Windows 10 with Firefox and Flash Player and getting it to work. I cannot post the URL because the application is a inhouse application and requires logging in.
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0

More Information

Question owner

Want to report that Content Blocking was turned off entirely and still could not see Flash Player content being displayed.

Want to report that Content Blocking was turned off entirely and still could not see Flash Player content being displayed.
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
3853 solutions 53565 answers

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: Tracking Protection {web link}

Make sure you are not blocking content. [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? --------------- One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: [https://support.mozilla.org/en-US/kb/tracking-protection Tracking Protection] {web link}
Was this helpful to you?
Quote

Question owner

Just tried on a Windows 10 system.

Starting Firefox in Safe mode (not refresh) did not change the behavior. Windows 10/Firefox/FlashPlayer is not displaying content.

If the right mouse button is clicked, we see the mouse menu for Flash Player. Just no content is being displayed under this configuration.

Thanks,

Just tried on a Windows 10 system. Starting Firefox in Safe mode (not refresh) did not change the behavior. Windows 10/Firefox/FlashPlayer is not displaying content. If the right mouse button is clicked, we see the mouse menu for Flash Player. Just no content is being displayed under this configuration. Thanks,

Modified by TonyK59

Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
3853 solutions 53565 answers

Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

Start your '''Computer''' in safe mode with network support. Then start Firefox. Try '''Secure''' websites. Is the problem still there? http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia
Was this helpful to you? 0
Quote

Question owner

Not sure what starting a computer in Safe Mode is going to do about an application that is not rendering Flash content. The issue lies with Windows 10, Firefox and Flash Player.

I realize the intent is to try and reduce the number of variables involved but we will still have an issue between Flash Player and Firefox under Windows 10.

But starting Firefox in Private viewing mode does get Flash content to display.

The answer, at least until Mozilla fixes Firefox, is to start Firefox in Private viewing mode.

This will be a hassle for the population of our 800,000 users who may be using Firefox under Windows 10. Hopefully Mozilla will fix this issue and not just ignore it.

Not sure what starting a computer in Safe Mode is going to do about an application that is not rendering Flash content. The issue lies with Windows 10, Firefox and Flash Player. I realize the intent is to try and reduce the number of variables involved but we will still have an issue between Flash Player and Firefox under Windows 10. But starting Firefox in Private viewing mode does get Flash content to display. The answer, at least until Mozilla fixes Firefox, is to start Firefox in Private viewing mode. This will be a hassle for the population of our 800,000 users who may be using Firefox under Windows 10. Hopefully Mozilla will fix this issue and not just ignore it.

Modified by TonyK59

Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
3853 solutions 53565 answers

Is the problem with some websites, a few?

Is the problem with some websites, a few?
Was this helpful to you?
Quote

Question owner

FredMcD said

Is the problem with some websites, a few?

Objects in question:

Flash Player version 32.0.0.101 Firefox version 64 (64-bit)

What has been seen is running the same versions of FlashPlayer and Firefox results in different operation between Windows 7 and Windows 10. Windows 7 works. Windows 10 does not work. To only workaround is to start FF up in Privacy mode under Windows 10.

This is not desirable.

''FredMcD [[#answer-1183012|said]]'' <blockquote> Is the problem with some websites, a few? </blockquote> Objects in question: Flash Player version 32.0.0.101 Firefox version 64 (64-bit) What has been seen is running the same versions of FlashPlayer and Firefox results in different operation between Windows 7 and Windows 10. Windows 7 works. Windows 10 does not work. To only workaround is to start FF up in Privacy mode under Windows 10. This is not desirable.
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
3853 solutions 53565 answers

One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: Tracking Protection {web link}

One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: [https://support.mozilla.org/en-US/kb/tracking-protection Tracking Protection] {web link}
Was this helpful to you? 0
Quote
jscher2000
  • Top 10 Contributor
8025 solutions 65562 answers

Helpful Reply

TonyK59 said

But starting Firefox in Private viewing mode does get Flash content to display. The answer, at least until Mozilla fixes Firefox, is to start Firefox in Private viewing mode.

Hmm, interesting. In private windows, Flash may be limited to writing to memory instead of disk. That's a good clue.

Firefox 64 ratcheted up security for SWF apps, reducing their ability to read content from your system. You could roll back the sandbox security level to see whether it makes any difference for the media that is giving you problems.

To experiment with that setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste sand and pause while the list is filtered

(3) The dom.ipc.plugins.sandbox-level.flash preference restricts what Flash content can do on your system. You can modify the value by double-clicking the preference:

  • 1 - blocks "write access to most of the filesystem", "exec" and "fork"
  • 2 - level 1 + blocks printing and "read access to most of the filesystem (with some read access allowed, triggered by Flash file dialog activity, however this does not work reliably)"
  • 3 (default in Fx64) - levels 1-2 + blocks "read access to most of the filesystem (without any support for file dialogs)"

Maybe try lowering the sandbox level to 2 and see what difference that makes. It may not take effect until you unload all the Flash content in Firefox; it may be easiest to exit out of Firefox and starting it up again before testing.

Unfortunately, this is a not a per-site setting, it applies to all sites. However, you can control which sites use Flash on a per-site basis. See: Why do I have to click to activate plugins?

''TonyK59 [[#answer-1182973|said]]'' <blockquote> But starting Firefox in Private viewing mode does get Flash content to display. The answer, at least until Mozilla fixes Firefox, is to start Firefox in Private viewing mode. </blockquote> Hmm, interesting. In private windows, Flash may be limited to writing to memory instead of disk. That's a good clue. Firefox 64 ratcheted up security for SWF apps, reducing their ability to read content from your system. You could roll back the sandbox security level to see whether it makes any difference for the media that is giving you problems. To experiment with that setting: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''sand''' and pause while the list is filtered (3) The '''dom.ipc.plugins.sandbox-level.flash''' preference restricts what Flash content can do on your system. You can modify the value by double-clicking the preference: * '''1''' - blocks "write access to most of the filesystem", "exec" and "fork" * '''2''' - level 1 + blocks printing and "read access to most of the filesystem (with some read access allowed, triggered by Flash file dialog activity, however this does not work reliably)" * '''3''' (<u>default in Fx64</u>) - levels 1-2 + blocks "read access to most of the filesystem (without any support for file dialogs)" Maybe try lowering the sandbox level to '''2''' and see what difference that makes. It may not take effect until you unload all the Flash content in Firefox; it may be easiest to exit out of Firefox and starting it up again before testing. Unfortunately, this is a not a per-site setting, it applies to all sites. However, you can control which sites use Flash on a per-site basis. See: [[Why do I have to click to activate plugins?]]
Was this helpful to you? 1
Quote

Question owner

Hi jscher2000,

I can try this for debugging the issue.

We cannot do this against a user base of 800,000 users. We do not want to try and write those instructions to be bullet-proof nor do we want all those users modifying their Firefox setup. This can have very bad consequences for the user and for us.

Let me discuss with some others and will hopefully report back soon.

Thank you,

Hi jscher2000, I can try this for debugging the issue. We cannot do this against a user base of 800,000 users. We do not want to try and write those instructions to be bullet-proof nor do we want all those users modifying their Firefox setup. This can have very bad consequences for the user and for us. Let me discuss with some others and will hopefully report back soon. Thank you,
Was this helpful to you?
Quote

Question owner

jscher2000 said

TonyK59 said
But starting Firefox in Private viewing mode does get Flash content to display. The answer, at least until Mozilla fixes Firefox, is to start Firefox in Private viewing mode.

Hmm, interesting. In private windows, Flash may be limited to writing to memory instead of disk. That's a good clue.

Firefox 64 ratcheted up security for SWF apps, reducing their ability to read content from your system. You could roll back the sandbox security level to see whether it makes any difference for the media that is giving you problems.

To experiment with that setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste sand and pause while the list is filtered

(3) The dom.ipc.plugins.sandbox-level.flash preference restricts what Flash content can do on your system. You can modify the value by double-clicking the preference:

  • 1 - blocks "write access to most of the filesystem", "exec" and "fork"
  • 2 - level 1 + blocks printing and "read access to most of the filesystem (with some read access allowed, triggered by Flash file dialog activity, however this does not work reliably)"
  • 3 (default in Fx64) - levels 1-2 + blocks "read access to most of the filesystem (without any support for file dialogs)"

Maybe try lowering the sandbox level to 2 and see what difference that makes. It may not take effect until you unload all the Flash content in Firefox; it may be easiest to exit out of Firefox and starting it up again before testing.

Unfortunately, this is a not a per-site setting, it applies to all sites. However, you can control which sites use Flash on a per-site basis. See: Why do I have to click to activate plugins?

Hi,

My inside user on Windows 10 made the change and it worked.

As mentioned earlier, we are not able to walk up to 800,000 users (potential users) through this change. Just not possible.

What are our options?

''jscher2000 [[#answer-1186041|said]]'' <blockquote> ''TonyK59 [[#answer-1182973|said]]'' <blockquote> But starting Firefox in Private viewing mode does get Flash content to display. The answer, at least until Mozilla fixes Firefox, is to start Firefox in Private viewing mode. </blockquote> Hmm, interesting. In private windows, Flash may be limited to writing to memory instead of disk. That's a good clue. Firefox 64 ratcheted up security for SWF apps, reducing their ability to read content from your system. You could roll back the sandbox security level to see whether it makes any difference for the media that is giving you problems. To experiment with that setting: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''sand''' and pause while the list is filtered (3) The '''dom.ipc.plugins.sandbox-level.flash''' preference restricts what Flash content can do on your system. You can modify the value by double-clicking the preference: * '''1''' - blocks "write access to most of the filesystem", "exec" and "fork" * '''2''' - level 1 + blocks printing and "read access to most of the filesystem (with some read access allowed, triggered by Flash file dialog activity, however this does not work reliably)" * '''3''' (<u>default in Fx64</u>) - levels 1-2 + blocks "read access to most of the filesystem (without any support for file dialogs)" Maybe try lowering the sandbox level to '''2''' and see what difference that makes. It may not take effect until you unload all the Flash content in Firefox; it may be easiest to exit out of Firefox and starting it up again before testing. Unfortunately, this is a not a per-site setting, it applies to all sites. However, you can control which sites use Flash on a per-site basis. See: [[Why do I have to click to activate plugins?]] </blockquote> Hi, My inside user on Windows 10 made the change and it worked. As mentioned earlier, we are not able to walk up to 800,000 users (potential users) through this change. Just not possible. What are our options?
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8025 solutions 65562 answers

Hi TonyK59, one option would be to figure out exactly what is blocked by the higher sandbox level and see whether you can avoid the need to do that in your SWF.

Does the Browser Console capture any information about Flash sandbox issues?

https://developer.mozilla.org/docs/Tools/Browser_Console

(I don't think I have a comparable app to investigate myself.)

If you cannot discover the issue, you could file a bug explaining what the SWF does that works at sandbox level 2 and see whether there is a way to work around the restrictions applied at sandbox level 3.

Hi TonyK59, one option would be to figure out exactly what is blocked by the higher sandbox level and see whether you can avoid the need to do that in your SWF. Does the Browser Console capture any information about Flash sandbox issues? https://developer.mozilla.org/docs/Tools/Browser_Console (I don't think I have a comparable app to investigate myself.) If you cannot discover the issue, you could file a bug explaining what the SWF does that works at sandbox level 2 and see whether there is a way to work around the restrictions applied at sandbox level 3. * https://developer.mozilla.org/docs/Mozilla/QA/Bug_writing_guidelines * https://bugzilla.mozilla.org/
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.