Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I just installed Firefox on a new device. Everuthing goes well except I cannot sign in on "my insurance" which works via a secured site DIGID in the Netherlands

  • 5 replies
  • 1 has this problem
  • 34 views
  • Last reply by joernst

more options

On all other devices I can sign in. And also with the Edge browser in this device I can sign in on my insurance. DigiD is an official site from the Dutch gouvernment to get acces to private websites

Chosen solution

What happens if you try to sign in?


This issue can be caused by corrupted cookies or cookies that are blocked.

Clear the Cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" from websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Manage Data

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
Read this answer in context 👍 0

All Replies (5)

more options

Please explain the problem in detail. What happens? What is the exact error messages?

Please provide a public link (no password) that we can check out. No Personal Information Please !

more options

I installed a new laptop Acer Aspire 3. with windows 10. On first sight, everything was ok. Surfing on internet was no problem, I could open all sites. But then I wanted to open the private part of my health-insurance site. I can only get access to this site via a secured site from our official government site DigiD in Holland.

I get access to this site, and I get access to the insurance site. But to get access to my private part of the insurance, I have to do this via DigiD. If I do this I only get the same site of the insurance site where I am asked to sign in via DigiD.

If I use the Edge browser, I have no problem, on my older laptop with Firefox, no problem either, I get directly my private site of the insurance.

I have deleted Firefox and installed it again, nothing works until now. I hope I am clear now Thanks for helping me Jo

more options

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

more options

Chosen Solution

What happens if you try to sign in?


This issue can be caused by corrupted cookies or cookies that are blocked.

Clear the Cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" from websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Manage Data

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

I just received a new update from Mozilla and I have downmoaded manually the latest

adobe Flash. And now everything works ok. Thank you foor your help Jo