Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox keeps opening last viewed page after start

  • 3 replies
  • 1 has this problem
  • 29 views
  • Last reply by ygreko

more options

When I close Firefox on Windows, and then run it again after some time, is opens my last viewed page. I don't want this, I unchecked the option in settings, I even edited about:config and this is still happening. It is making me crazy and I am using Firefox for one day only, and will come back to Chrome if this keeps doing this idiotic thing.

How to turn the option for good?

All Replies (3)

more options

You may have corrupt sessionstore [v56] sessionstore.jsonlz4 file(s). Delete all sessionstore* files and the sessionstore-backups folder.

Type about:support<enter> in the address bar.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Linux: Under the page logo on the left side, you will see Application Basics. Under this find Profile Directory. To its right press the button Open Directory.

Locate the above file. Then rename or delete it. Restart Firefox.


Don't delete the files if you need to rescue any data from them, just move them out of the profile folder to some location where Firefox doesn't look for them. You can try to read out their contents using this tool: https://www.jeffersonscher.com/res/scrounger.html

more options

If you use "Show my windows and tabs from last time" then Firefox opens the page in the first tab if you close this last tab to close Firefox.

To prevent this you can toggle this pref to false on the about:config page to prevent Firefox from closing if you close the last tab.

  • browser.tabs.closeWindowWithLastTab = false

You will have to close Firefox via one of these instead.

  • "3-bar" menu button -> Exit (Power button)
  • Windows: File -> Exit
  • Mac: Firefox -> Quit Firefox
  • Linux: File -> Quit

You can check if you have a user.js file in the Firefox profile folder that sets the browser.sessionstore.resume_session_once pref to true.

more options

Thanks, @cor-el. Hope that will help, I will observe it now.