X
Tap here to go to the mobile version of the site.
An updated version of Firefox is available to address the issues with Add-ons disabled or fail to install on Firefox. You can download the update for your OS here: https://www.mozilla.org/firefox/new/ For Known Issues and Workarounds, please check out the update at https://support.mozilla.org/kb/add-ons-disabled-or-fail-to-install-firefox

Support Forum

There is no Menu or Preferences option to deselect Firefox as your default browser. Why?

Posted

Hi, A few weeks ago, in a rush, I inadvertently opted to make Firefox my default browser. This has proved problematic as I normally use another browser which suits me better. Looking in Preferences there appears to be no way of deselecting Firefox as your default browser. Shall I just remove Firefox and start again?

Hi, A few weeks ago, in a rush, I inadvertently opted to make Firefox my default browser. This has proved problematic as I normally use another browser which suits me better. Looking in Preferences there appears to be no way of deselecting Firefox as your default browser. Shall I just remove Firefox and start again?

Chosen solution

Hello curiouscat,

You can no longer remove Firefox as your default browser in the Firefox menu => Preferences - all you have to do is to set your preferred browser as default on your system :

Go to Safari => Preferences. While on the General tab, select the browser you want to use as default from the drop down menu.

Then you'll see in Firefox's Preferences that Firefox is no longer the default browser.

Read this answer in context 1

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_1) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/12.0.1 Safari/605.1.15

More Information

McCoy
  • Top 10 Contributor
396 solutions 3449 answers

Chosen Solution

Hello curiouscat,

You can no longer remove Firefox as your default browser in the Firefox menu => Preferences - all you have to do is to set your preferred browser as default on your system :

Go to Safari => Preferences. While on the General tab, select the browser you want to use as default from the drop down menu.

Then you'll see in Firefox's Preferences that Firefox is no longer the default browser.

Hello curiouscat, You can no longer remove Firefox as your default browser in the Firefox menu => Preferences - all you have to do is to set your preferred browser as default on your system : Go to Safari => Preferences. While on the General tab, select the browser you want to use as default from the drop down menu. Then you'll see in Firefox's Preferences that Firefox is no longer the default browser.

Question owner

Many thanks McCoy. Problem solved, though I do think Firefox could be clearer about this in its Menu, Preferences and Troubleshooting options. What should have taken 2 minutes has taken over an hour to resolve.

Many thanks McCoy. Problem solved, though I do think Firefox could be clearer about this in its Menu, Preferences and Troubleshooting options. What should have taken 2 minutes has taken over an hour to resolve.
McCoy
  • Top 10 Contributor
396 solutions 3449 answers

Curiouscat said

Many thanks McCoy. Problem solved, though I do think Firefox could be clearer about this in its Menu, Preferences and Troubleshooting options. What should have taken 2 minutes has taken over an hour to resolve.

I'm really sorry you wasted so much time on this .... Unfortunately there is nothing that we (volunteer contributors) can do about it  :(

Maybe you'd like to give feedback here :

https://qsurvey.mozilla.com/s3/FirefoxInput/

(I'm glad your problem is solved though  !)

''Curiouscat [[#answer-1174107|said]]'' <blockquote> Many thanks McCoy. Problem solved, though I do think Firefox could be clearer about this in its Menu, Preferences and Troubleshooting options. What should have taken 2 minutes has taken over an hour to resolve. </blockquote> I'm really sorry you wasted so much time on this .... Unfortunately there is nothing that we (volunteer contributors) can do about it :( Maybe you'd like to give feedback here : https://qsurvey.mozilla.com/s3/FirefoxInput/ (I'm glad your problem is solved though !)