Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Calendar notifications automatically disappear after few seconds - this is dangerous and has caused me to miss important meetings

  • 6 replies
  • 1 has this problem
  • 15 views
  • Last reply by McCoy

more options

I have been regularly missing appointments since switching to Firefox and could not figure out why. I discovered that, unlike Chrome, calendar reminders in Firefox automatically disappear after a few seconds. If I am not in front of my computer during the 4 second window the reminder is there, I miss the reminder completely. This seems like a very poor design choice. I believe that I need to switch back to Chrome to prevent missing more meetings.

All Replies (6)

more options

I don't recall firefox being a calendar program but a Browser.

more options

Hello phugel,

Is this about Thunderbird Calendar, Windows Calendar, or Google Calendar  ?

You could check the settings :

Thunderbird Calendar : https://support.mozilla.org/en-US/kb/changing-calendar-preferences

Windows Calendar : https://support.office.com/en-us/article/change-the-default-reminder-time-58414862-1a3a-4344-ad15-a5f14a750e95

Google Calendar : https://calendar.google.com/calendar/r/settings?tab=wc

more options

The issue seems to be related to Firefox, not the calendar itself (which is Google Calendar). When Chrome is running, Chrome generates pop-up notifications for Google Calendar events which remain on screen until closed. Firefox also generates nearly identical pop-up notifications of Google Calendar events (via Web Push notification I believe) but the Firefox notifications automatically close after about 4 seconds. Settings in Google Calendar and Firefox allow the user to control whether or not Google Calendar pop-up notifications will appear, but do not (to the best of my knowledge) allow the user to modify how a pop-up notification behaves after it appears.

There have been several instances since I switched to Firefox in which I missed an appointment because I was on the phone or in the bathroom, or doing something other than looking at my screen during the 4 seconds in which the Firefox notification appeared.

It seems to me that, by default, calendar notifications should remain on screen until they are closed by the user - or at least this should be an option. The work around I have come up with is to always leave Chrome running in the background, even if I am using Firefox for my web browsing. I now receive two pop-ups simultaneously for each appointment - one from Chrome and one from Firefox. While the Firefox notification disappears within seconds, the Chrome pop-up stay open until I dismiss it, ensuring that I actually see the notification asked to receive.

more options

Would you please check the settings for pop-up windows and notifications in the 3-bar menu (or Tools) => Options =>
Privacy & Security => under 'Permissions'  ?

more options

That is the first place I looked, assuming that it would allow me to tweak the notification behavior. An entry for Google Calendar appears in the notification settings menu. However, the only settings available are "Allow" or "Block". It is set for Allow. Screen shot attached

more options

If everything else fails (I noticed there was a bug report a bout this some years ago), would you take a look at this add-on please :

https://addons.mozilla.org/en-US/firefox/addon/checker-plus-for-calendar/

The reviews are good - worth a try ......