X
Tap here to go to the mobile version of the site.
An updated version of Firefox is available to address the issues with Add-ons disabled or fail to install on Firefox. You can download the update for your OS here: https://www.mozilla.org/firefox/new/ For Known Issues and Workarounds, please check out the update at https://support.mozilla.org/kb/add-ons-disabled-or-fail-to-install-firefox

Support Forum

Back arrow reverts to an old cached page, not the last one I viewed.

Posted

I think this is a bug. If I browse to the next level down then try to go back using the back arrow, the page that appears is the one from a cache last time I was on the site, not the correct page.

I think this is a bug. If I browse to the next level down then try to go back using the back arrow, the page that appears is the one from a cache last time I was on the site, not the correct page.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 31.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

More Information

FredMcD
  • Top 10 Contributor
4083 solutions 57022 answers

Helpful Reply

I get around this by; When I find a link I want to check out, I open it in a new tab/window. Then when I am done, I close it and am back where I started.


Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings.

Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.

I get around this by; When I find a link I want to check out, I open it in a new tab/window. Then when I am done, I close it and am back where I started. ---------------- Type '''about:preferences#privacy'''<enter> in the address bar. The button next to '''History, ''' select '''Use Custom Settings. ''' Turn on '''Remember My Browsing And Download History''' At the bottom of the page, turn on '''Clear History When Firefox Closes. ''' At the far right, press the '''Settings''' button. Turn on ONLY '''Cache''' and '''Form And Search History''' leaving the others off.

Question owner

Thank you for your help here. Ironically, I cannot reproduce the problem today anyway. I'll wait for it to happen again.

Thank you for your help here. Ironically, I cannot reproduce the problem today anyway. I'll wait for it to happen again.