Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

This thread was closed and archived. Please ask a new question if you need help.

for windows 10 edge plays you tube videos but firefox does not

  • 5 replies
  • 1 has this problem
  • 13 views
  • Last reply by jscher2000

more options

I just get a circle loading but nothing happens.

All Replies (5)

more options

Sounds like a bad firefox install or the browser got corrupted. How was it updated?

more options

Firefox was updated to version 63.0.1 on Nov 5. The status says it is updated.

more options

Hi Sal46, could you try in a private window, i.e., not logged into your YouTube account? You can right-click the link to the video, then choose Open in New Private Window. Any difference?

I mention that because a number of users have incomplete page loading or other odd symptoms when logged in to YouTube.


Otherwise, if a site is generally known to work in Firefox, these are standard suggestions to try when it stops working normally:

Double-check content blockers: Firefox's Tracking Protection feature and extensions that counter ads and tracking may break websites that weren't built to operate normally without the blocked components.

Do you see a shield icon toward the left end of the address bar, near the lock icon? More info on managing the Tracking Protection feature in this article: What happened to Tracking Protection?.

Extensions such as Adblock Plus, Blur, Disconnect, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site.

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "Clear Cookies and Site Data"
  • (menu bar) Tools > Page Info > Security > "Clear Cookies and Site Data"
  • click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "Clear Cookies and Site Data" button

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?

Testing in Firefox's Safe Mode: In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

more options

I don't have a you tube account but I tried the private window and you tube video still will not load. Turned off ad blocker plus still no difference. I cleared the cache last week no change. The other comments are above my head. Maybe I should just uninstall firefox and install a clean copy?

more options

Usually uninstalling/reinstalling Firefox doesn't help unless the problem is in the program files. The reason is that Firefox preserves your data.

The other stuff I mentioned is worth working through. If you can only try one thing, try Firefox's Safe Mode. This will help determine whether one of your add-ons is causing the problem.