X
Tap here to go to the mobile version of the site.

Support Forum

I see a black flashing line, like office word wherever I click

Posted

For example when I click on a video is see a flashing small line at the bottom left on youtube. Also for example if I press wherever on Mozilla there will a flashing line (like word or text editor) to the closest text box. I probably pressed a button that activated this. Does anybody know about it?

For example when I click on a video is see a flashing small line at the bottom left on youtube. Also for example if I press wherever on Mozilla there will a flashing line (like word or text editor) to the closest text box. I probably pressed a button that activated this. Does anybody know about it?

Chosen solution

Hi Jerryyyz, it sounds like Caret Browsing got turned on.

You can accidentally turn it on by pressing the F7 function key. F7 will also turn it off.

If F7 doesn't work, you can uncheck a box here:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type cursor and Firefox should filter to the "Browsing" section.

Uncheck the box for "Always use the cursor keys to navigate within pages"

Success?


By the way, there should be a confirmation dialog when you press F7 to turn on Caret Browsing that looks like the attached.

If this dialog is disabled, then F7 will turn on Caret Browsing automatically.

Here are some related settings:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste caret and pause while the list is filtered

To restore the F7 warning dialog:

(3) If the accessibility.warn_on_browsewithcaret preference is bolded and "modified" to false, double-click it to restore the default value of true

To prevent the F7 key from triggering caret browsing:

(4) Double-click the accessibility.browsewithcaret_shortcut.enabled preference to switch the value from true to false

Hope this helps.

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 31.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

More Information

jscher2000
  • Top 10 Contributor
8207 solutions 67138 answers

Chosen Solution

Hi Jerryyyz, it sounds like Caret Browsing got turned on.

You can accidentally turn it on by pressing the F7 function key. F7 will also turn it off.

If F7 doesn't work, you can uncheck a box here:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type cursor and Firefox should filter to the "Browsing" section.

Uncheck the box for "Always use the cursor keys to navigate within pages"

Success?


By the way, there should be a confirmation dialog when you press F7 to turn on Caret Browsing that looks like the attached.

If this dialog is disabled, then F7 will turn on Caret Browsing automatically.

Here are some related settings:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste caret and pause while the list is filtered

To restore the F7 warning dialog:

(3) If the accessibility.warn_on_browsewithcaret preference is bolded and "modified" to false, double-click it to restore the default value of true

To prevent the F7 key from triggering caret browsing:

(4) Double-click the accessibility.browsewithcaret_shortcut.enabled preference to switch the value from true to false

Hope this helps.

Hi Jerryyyz, it sounds like '''Caret Browsing''' got turned on. You can accidentally turn it on by pressing the F7 function key. F7 will also turn it off. If F7 doesn't work, you can uncheck a box here: * Windows: "3-bar" menu button (or Tools menu) > Options * Mac: "3-bar" menu button (or Firefox menu) > Preferences * Linux: "3-bar" menu button (or Edit menu) > Preferences * Any system: type or paste '''about:preferences''' into the address bar and press Enter/Return to load it In the search box at the top of the page, type ''cursor'' and Firefox should filter to the "Browsing" section. Uncheck the box for "Always use the cursor keys to navigate within pages" Success? ---- By the way, there should be a confirmation dialog when you press F7 to turn on Caret Browsing that looks like the attached. <img src="https://prod-cdn.sumo.mozilla.net/uploads/images/2018-10-31-09-35-04-5a37a9.png" width="500"> If this dialog is disabled, then F7 will turn on Caret Browsing automatically. Here are some related settings: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''caret''' and pause while the list is filtered ''To restore the F7 warning dialog:'' (3) If the '''accessibility.warn_on_browsewithcaret''' preference is bolded and "modified" to false, double-click it to restore the default value of true ''To prevent the F7 key from triggering caret browsing:'' (4) Double-click the '''accessibility.browsewithcaret_shortcut.enabled''' preference to switch the value from true to false Hope this helps.
Was this helpful to you? 1
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.