Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

My email links from Classmates will not open. It opens in Goggle.com instead. Why??

  • 16 replies
  • 2 have this problem
  • 22 views
  • Last reply by Matt

more options

I use Firefox and recently the links in my emails from Classmates will open. The window for Goggle.com opens instead. These links use to work and now I cannot get them to work at all. Can anyone give me some help on how to get the links to open correctly?

All Replies (16)

more options

Are you trying to open these links from inside Firefox, or something else.

Is Firefox your default browser?

Type about:preferences#general<enter> in the address bar. Turn on Make Firefox Default Browser. You can also turn on; Always Check Firefox Default Browser.

more options

Yes Firefox is my default browser. I am trying to open them from email links in Thunderbird which I use for my email.

more options

Thunderbird should be using the default browser. Try starting Thunderbird in Safe Mode; https://support.mozilla.org/en-US/kb/safe-mode-thunderbird

Is the problem still there?

more options

Do the links open properly if you paste them in the Firefox location/address bar?

more options

The links are hidden so you just have to click on them. I can open Classmates in Firefox but the email information does not show up there. I tried the safe mode and that does not help either.

more options

Right-click on some of the links and select Copy Link. Then post them here or send a Private Message to one of us.

more options

I sent you a private email first about this. But when I went back and tried a right click, copy, then pasted it in Firefox, it did work. So now I am completely confused as what is going on!!

more options

I will check the e-mail when I get it.

more options

I looked at the e-mail. The web address being used is a redirect link thru a 3rd party website. I don't know if that is the issue.

Cor-el, did you want to take a look?

more options

It could be helpful to check the email links.

Note that a possible cause for opening in a link in a search engine page could be that this isn't a fully qualified link with a protocol (http: or https:), but is still formatted to open the default browser. Very long links may also fail.

more options

I sent you a PM.

more options

Fred I did not get the PM.

more options

Sorry, I meant an e-mail.

more options

Was one of the above the email?

more options

Was able to do a right click and copy to get the link to open. I take it the long addr3ss is the problem and going through another web site is causing the problems. They worked in past so not sure what has changed all this.

more options

To diagnose problems with Thunderbird, try one of the following:

  • Restart Thunderbird with add-ons disabled (Thunderbird Safe Mode). On the Help menu, click on "Restart with Add-ons Disabled". If Thunderbird works like normal, there is an Add-on or Theme interfering with normal operations. You will need to re-enable add-ons one at a time until you locate the offender.
  • Restart the operating system in safe mode with Networking. This loads only the very basics needed to start your computer while enabling an Internet connection. Click on your operating system for instructions on how to start in safe mode: Windows 10, Windows 8, Windows 7, Windows Vista, Windows XP, OSX
If safe mode for the operating system fixes the issue, there's other software in your computer that's causing problems. Possibilities include but not limited to: AV scanning, virus/malware, background downloads such as program updates.