Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

prime info Spot took over my Google Search Engine

  • 1 reply
  • 1 has this problem
  • 2 views
  • Last reply by jscher2000

more options

Hi there, While working on a sound effects site, I somehow downloaded malware to my Mac. Now, every time I do a google search (in the address bar, and also in the google search bar, which I've since just removed), the google search results no longer come up. Instead, I'm redirected to a search engine called: http://search.primeinfospot.com/?tp1=dbc19016-3c27-4231-bf81-d50a9c367fda&kw=sarch

Going through my search history when this happened, it seems it came out of this "Browser Update" (here's the start of the site, removing all the gobbly gook that followed it but maybe but don't click on it to be safe?)

https://www.logicalplatforms.com/

I've tried simply adjusting my firefox settings. restoring default but firefox seems to think this is my default. any ideas on how to remove this and insure it's not doing other bad things to my comptuer? thanks!

All Replies (1)

more options

Thank you for sharing your add-ons list. "Search Updater" looks suspicious.

You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Command+Shift+a (Windows: Ctrl+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions.

Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Please disable or remove Search Updater. If in doubt about any of the others try disabling it.

After that, you should regain control of your settings. You then can restore your preferred default. See: Change your default search settings in Firefox.

Success?