Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 63.0 won't open in a new install of Mojave...activity monitor reports memory usage going up to 60+ GB until all application memory is full...

  • 1 reply
  • 1 has this problem
  • Last reply by AppaDave

more options

I just installed Mojave (OS X 10.14) and I've downloaded Firefox 5 times so far...all of the version 63.0s install fine but when I run them, they just put Firefox in the drop-down menu (nothing else) and within a minute or so, consume all of the available (real and virtual) memory - 60+ GB!

I can only Force Quit it. I can't use it at all.

The main reason I updated to Mojave (I was running 10.8) was to use Firefox!

Thanks for helping... Dave

All Replies (1)

more options

Just updated to 10.14.1 (Mojave update) and still the same problem: launching Firefox doesn't ever get me a window, the process just consumes all the available memory (real and virtual) until the OS sends me a message to force quit Firefox.

Safari and Chrome and Opera do not create this problem.

I tried downgrading to no avail.

I can't believe that I'm alone here, but I also can't believe there isn't a simple solution...any advice is welcomed!

I really miss Firefox!