X
Tap here to go to the mobile version of the site.

Support Forum

Firefox takes a long time until it starts with loading a new page

Posted

Hello,

since the last update (v63.0, Windows) I have an issue that makes Firefox not usable. I hope you can help me.

Every time I open a new webpage, over a hyperlink or manually, Firefox takes 5-8 seconds until it starts to load the page. It seems like Firefox does nearly nothing at this point, there is no traffic going out, no CPU usage etc. There is also no status message in the bottom left corner like "Waiting for https://foobar.com...". After 5-8 seconds Firefox starts to load the page and then it goes very fast. This makes it impossible to use Firefox, because normal activities take a lot of time, because every click takes 5-8 seconds. On chrome on the same PC everything is OK.

I already did nearly everything to reset and clear my Firefox installation, I reinstalled and deleted the Mozilla folder in the AppData directory, the problem still persists. My colleague has the same issue since this update, so it's not only my PC.

I hope you can help me.

Hello, since the last update (v63.0, Windows) I have an issue that makes Firefox not usable. I hope you can help me. Every time I open a new webpage, over a hyperlink or manually, Firefox takes 5-8 seconds until it starts to load the page. It seems like Firefox does nearly nothing at this point, there is no traffic going out, no CPU usage etc. There is also no status message in the bottom left corner like "Waiting for https://foobar.com...". After 5-8 seconds Firefox starts to load the page and then it goes very fast. This makes it impossible to use Firefox, because normal activities take a lot of time, because every click takes 5-8 seconds. On chrome on the same PC everything is OK. I already did nearly everything to reset and clear my Firefox installation, I reinstalled and deleted the Mozilla folder in the AppData directory, the problem still persists. My colleague has the same issue since this update, so it's not only my PC. I hope you can help me.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 31.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

More Information

philipp
  • Top 25 Contributor
  • Moderator
5304 solutions 23419 answers

hi, could you check in the firefox menu ≡ > options > general panel if you have set firefox to connect directly to the internet (="no proxy") or if not doe it make a difference if you set it like that?

hi, could you check in the firefox ''menu ≡ > options > general'' panel if you have set firefox to connect directly to the internet (="no proxy") or if not doe it make a difference if you set it like that?
FredMcD
  • Top 10 Contributor
4245 solutions 59390 answers
[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? https://support.mozilla.org/kb/Firefox+is+already+running+but+is+not+responding https://support.mozilla.org/en-US/kb/firefox-slow-how-make-it-faster https://support.mozilla.org/en-US/kb/firefox-uses-too-many-cpu-resources-how-fix https://support.mozilla.org/en-US/kb/firefox-uses-too-much-memory-ram https://support.mozilla.org/en-US/kb/firefox-hangs-or-not-responding