Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

can't uninstall 63.0

  • 2 replies
  • 1 has this problem
  • 26 views
  • Last reply by macsm

more options

Recent problems made it necessary to reset Firefox 62.0.3 to its defaults. Unfortunately, did not realize this included automatic update installs which I never allow. When Firefox was launched this A.M. 63.0 was automatically installed and, unfortunately, has some kind of bug causing video flickering. Tried to uninstall by simply deleting the program, but Firefox continues to operate under 63.0 and will not uninstall even though program was deleted and trash emptied (Mac).

Could someone please explain why this is occurring and how to get rid of it?

Thanks.

All Replies (2)

more options

Have you tried disabling Hardware Acceleration? Turning off hardware acceleration

Also, I'd suggest updating Mac, at least to El Capitan, or High Sierra if your computer can support it. You also need to keep Firefox up to date, as running an out of date browser is not safe.

more options

Thank you for your reply. Hardware acceleration was already turned off so that was not the problem.

The good news is that I was able to disable it. Being anal retentive saved my bacon.

I never use the auto-update function for any application. My habit is to first download the program and then create two copies of it: one that will be opened and one that will be archived.

The problem with this 63.0 update was that there was no application to delete because it was installed from the internet rather than from my computer AND somehow, it corrupted the version that was running previously so that clicking on the 62.0.3 version automatically brought up 63.0.

What solved the problem was deleting the corrupted 62.0.3 application and launching the disk image from the archive which had never been opened or corrupted. This solved the problem AND, I've corrected the issue that allowed the auto-update to occur in the first place. This is precisely the reason why I do not allow auto-updates.

As to updating the OS, I've put it off because, frankly, I'm tired of having to upgrade all of my peripherals because they are not supported by a later OS. This OS works well with my printers/scanners/WACOM tablet, and I don't want to rock the boat.

Thanks again.