X
Tap here to go to the mobile version of the site.

Support Forum

Why do I keep getting error message: 'You are submitting too quickly. Please wait a few seconds...'

Posted

This is happening frequently but not everything I am submitting comments to websites. I submit the data, receive the message, and sometimes try up to ten more times over the course of several hours, and always receive the same message. I have updated my Firefox browser and it has not made any difference. Any help will be most appreciated. Kind regards, Andrew

This is happening frequently but not everything I am submitting comments to websites. I submit the data, receive the message, and sometimes try up to ten more times over the course of several hours, and always receive the same message. I have updated my Firefox browser and it has not made any difference. Any help will be most appreciated. Kind regards, Andrew

Additional System Details

Installed Plug-ins

  • Shockwave Flash 31.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0

More Information

WestEnd
  • Top 10 Contributor
59 solutions 5047 answers

Which sites? Some sites have preset time before you can submit to prevent Spamming bots. And sometimes you thought you clicked once but the mouse or "Enter" key is recognized as multiple inputs. If that is happening often then I would check both to see if mouse has dirty sensors or keyboard keys are stuck.

Which sites? Some sites have preset time before you can submit to prevent Spamming bots. And sometimes you thought you clicked once but the mouse or "Enter" key is recognized as multiple inputs. If that is happening often then I would check both to see if mouse has dirty sensors or keyboard keys are stuck.
cor-el
  • Top 10 Contributor
  • Moderator
17003 solutions 153538 answers

Helpful Reply

Clear the Cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" from websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Manage Data

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
Clear the Cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences). "Remove the Cookies" from websites that cause problems: *Options/Preferences -> Privacy & Security<br>Cookies and Site Data -> Manage Data "Clear the Cache": *Options/Preferences -> Privacy & Security<br>Cookies and Site Data -> Clear Data -> Cached Web Content: Clear Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if <u>hardware acceleration</u> is is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems

Question owner

Many thanks for your help.

Many thanks for your help.