Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Wordpress avatar stopped showing up

  • 7 replies
  • 1 has this problem
  • 17 views
  • Last reply by ForestMaven

more options

I can see my avatar in Chrome but in Mozilla I can't see it in my profile nor on the website. What's up and how can I fix it?

All Replies (7)

more options

This one?

What do you get instead of your own avatar?

Does anything in this article help: Fix problems that cause images to not show.

more options

I cleared the cache. I did not do all the other things as it worked perfectly before last week. I think Bluehost was trying to copy my website for a backup and after that it didn't work.

See screenshot below.

more options

I since have turned my computer off and back on. Still have same problem.

more options

Your avatar has this URL

Actual link with fallback

Can you open either in a new tab?


If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block (wanted) content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block (wanted) content.

If images are missing then check that you do not block images from some domains.

  • you can tap the Alt key or press the F10 key to show the hidden Menu Bar temporarily

check the permissions for the domain in the currently selected tab in "Tools -> Page Info -> Permissions".

Check "Tools -> Page Info -> Media" for blocked images

  • select the first image and use the cursor Down key to scroll through the list
  • if an image in the list is grayed and "Block Images from..." has a checkmark then remove this checkmark to unblock images from this domain

You can check this pref on the about:config page.

  • permissions.default.image (1)

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.

See also:

more options

Yes, I can see both. I refreshed Firefox. I disabled all my extensions. Now my avatar shows up unless I sign in. When I sign in to WP it is not there in my profile. When I go to my blog from there, it used to go directly, now it kicks me out of being signed in to WP.

more options

ForestMaven said

I refreshed Firefox. I disabled all my extensions. Now my avatar shows up unless I sign in. When I sign in to WP it is not there in my profile.

Could this be an HTTP vs. HTTPS issue -- does that vary depending on whether you are signed in?

When I go to my blog from there, it used to go directly, now it kicks me out of being signed in to WP.

Hmm, that's strange. This suggests that the cookie the site uses to recognize that you are logged in is getting lost. That wouldn't normally happen if you just follow a link in the same tab or even in a different tab. It could occur if you launched the link across a trust boundary, such as between a regular window and a private window, or between "containers" if you are using container tabs (most people haven't heard of them and aren't using them).

more options

I tried it again, and now it works OK with the avatars and does not lose my info. I reenabled all my plug ins and finally reinstalled the last ones and now it all seems to work.

This has happened before that the recognition cookie for Wordpress got lost, last time it went on for 3 or 4 days before it seemed to fix itself.

Thanks much for all your help!