X
Tap here to go to the mobile version of the site.

Support Forum

Can't select items on Dell.com (Dell XPS 15 Customization) page with Firefox 62.0.3 running on Windows 7 Pro 32 bit. Page works correctly with Chrome.

Posted

I have Firefox 62.0.3 (with * Shockwave Flash 31.0 r0) installed on my Dell Latitude 6510 running Windows 7 Pro 32 bit. I searched (with google) for Dell XPS 15 and found a number of interesting configurations on the dell.com web site. Selecting one of these I then tried to customize the configuration, but none of the options buttons on the page (e.g. Select Windows 10 Pro instead of the default Windows 10 Home OS) work. Further, about 90% of the time after selecting the config option to change the page will freeze and then after a bit FF will crash with a "Gah! ...." message. I thought it was the Dell web page that was screwing up until I loaded the Chrome browser, did the same search and found that everything on the Dell page worked as expected. Hence I suspect some problem with FF 62.0.3 (or maybe Adobe Flash??).

Here is the exact URL that I was trying to interact with that FF crashed or failed to work correctly on

https://www.dell.com/en-us/shop/cty/pdp/spd/xps-15-9570-laptop/dycwb1651h?cid=310435&st=&gclid=EAIaIQobChMI28a19oqK3gIVDI_ICh0jnQhXEAQYASABEgJaPfD_BwE&lid=5860376&ptaid=aud-339243926551:pla-388097301284&VEN1=spNqusC7B,183144151912,901pdb6671,c,,DYCWB1651H,41387734718,aud-339243926551:pla-388097301284&VEN2=,&pgrid=41387734718&dgc=st&dgseg=dhs&acd=1230980731501410&VEN3=810704618536863973

I have Firefox 62.0.3 (with * Shockwave Flash 31.0 r0) installed on my Dell Latitude 6510 running Windows 7 Pro 32 bit. I searched (with google) for Dell XPS 15 and found a number of interesting configurations on the dell.com web site. Selecting one of these I then tried to customize the configuration, but none of the options buttons on the page (e.g. Select Windows 10 Pro instead of the default Windows 10 Home OS) work. Further, about 90% of the time after selecting the config option to change the page will freeze and then after a bit FF will crash with a "Gah! ...." message. I thought it was the Dell web page that was screwing up until I loaded the Chrome browser, did the same search and found that everything on the Dell page worked as expected. Hence I suspect some problem with FF 62.0.3 (or maybe Adobe Flash??). Here is the exact URL that I was trying to interact with that FF crashed or failed to work correctly on https://www.dell.com/en-us/shop/cty/pdp/spd/xps-15-9570-laptop/dycwb1651h?cid=310435&st=&gclid=EAIaIQobChMI28a19oqK3gIVDI_ICh0jnQhXEAQYASABEgJaPfD_BwE&lid=5860376&ptaid=aud-339243926551:pla-388097301284&VEN1=spNqusC7B,183144151912,901pdb6671,c,,DYCWB1651H,41387734718,aud-339243926551:pla-388097301284&VEN2=,&pgrid=41387734718&dgc=st&dgseg=dhs&acd=1230980731501410&VEN3=810704618536863973

Additional System Details

Installed Plug-ins

  • Shockwave Flash 31.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:62.0) Gecko/20100101 Firefox/62.0

More Information

FredMcD
  • Top 10 Contributor
4257 solutions 59604 answers

Helpful Reply

Gah-Your-tab-just-crashed https://support.mozilla.org/en-US/kb/firefox-crashes-troubleshoot-prevent-and-get-help


Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

Gah-Your-tab-just-crashed https://support.mozilla.org/en-US/kb/firefox-crashes-troubleshoot-prevent-and-get-help --------------- Many site issues can be caused by corrupt cookies or cache. * Clear the Cache and * Remove Cookies '''Warning ! ! ''' This will log you out of sites you're logged in to. You may also lose any settings for that website. * '''Cookies; ''' [https://support.mozilla.org/en-US/kb/delete-cookies-remove-info-websites-stored Delete cookies to remove the information websites have stored on your computer] {web link} * '''Cache; ''' [https://support.mozilla.org/en-US/kb/how-clear-firefox-cache How to clear the Firefox cache] {web link} If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Did this help? While you are in safe mode; Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches. ''[https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration How to disable Hardware Acceleration]'' {web link}

Question owner

Clearing history, cookies and cache did NOT resolve the issue. Starting Firefox in Safe mode DID resolve the issue. In Safe Mode I could check each Dell configuration option and the price of the device updated correspondingly.

So this brings up the question, is this a Dell web site or Firefox issue? Also, what's different about starting in Safe Mode?

Clearing history, cookies and cache did NOT resolve the issue. Starting Firefox in Safe mode DID resolve the issue. In Safe Mode I could check each Dell configuration option and the price of the device updated correspondingly. So this brings up the question, is this a Dell web site or Firefox issue? Also, what's different about starting in Safe Mode?
FredMcD
  • Top 10 Contributor
4257 solutions 59604 answers

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

It could be the work of one of your add-ons, or it could be '''Hardware Acceleration. ''' ''[https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration How to disable Hardware Acceleration]'' {web link} Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control> ''(Mac=<Command>)'' <Shift> A) ''' In the Add-ons Manager, on the left, select '''Extensions. ''' Disable a few add-ons, then '''Restart Firefox. ''' Some added toolbar and anti-virus add-ons are known to cause Firefox issues. '''Disable All Of them. ''' If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group '''ONE AT A TIME''' (restarting FF) until the problem returns. Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

Question owner

I did NOT have hardware acceleration enabled (so my guess is that that was NOT the problem).

I did have 3 add ons running. ABP - Adblock Plus Norton Safe Web Norton Safe Search

I disabled ABP first and I could then select the Dell web page radio buttons (and see the platform price reflect the changes). But within about 5 minutes the tab crashed. So with ABP disabled I disabled Norton Safe Search. Same result, buttons accessible but a crash within 5 minutes. Finally with ABP and Norton Safe Search disabled, I disabled Norton Safe Web. At that point I could toggle any radio button and the page would react properly and it didn't crash with several minutes of activity.

So it seems that all 3 of my add ons were the culprit.

Thank you for your help with this!

I did NOT have hardware acceleration enabled (so my guess is that that was NOT the problem). I did have 3 add ons running. ABP - Adblock Plus Norton Safe Web Norton Safe Search I disabled ABP first and I could then select the Dell web page radio buttons (and see the platform price reflect the changes). But within about 5 minutes the tab crashed. So with ABP disabled I disabled Norton Safe Search. Same result, buttons accessible but a crash within 5 minutes. Finally with ABP and Norton Safe Search disabled, I disabled Norton Safe Web. At that point I could toggle any radio button and the page would react properly and it didn't crash with several minutes of activity. So it seems that all 3 of my add ons were the culprit. Thank you for your help with this!
FredMcD
  • Top 10 Contributor
4257 solutions 59604 answers

Good to hear. Contact Norton support.

https://support.norton.com

http://community.norton.com/

Good to hear. Contact Norton support. https://support.norton.com http://community.norton.com/