Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox is completely unresponsive

  • 7 replies
  • 2 have this problem
  • 230 views
  • Last reply by FredMcD

more options

I have just installed the latest version of Firefox. However, when I launch the program, the screen is blank and no welcome screen or search window shows up. The screen is just a blank white. If I try to go to a website or search for something, the browser does not do anything, it just sits at the blank screen. Whenever I try to open the options from the Firefox menu, I cannot select any of the options within that menu. Any time I click on something, there is no response. I also have a huge list of options within my right-click context menu, which is really strange. Overall, Firefox is completely unresponsive and does not allow me to do anything. I can't even close the windows, I have to force close them through task manager.

I have tried to reinstall the program by deleting all old directory files after the uninstall. I have tried running the program in safe mode, but I am still not able to select any menu options or search for any websites. Thank you for your time and consideration, I hope we can find a solution!

Chosen solution

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

Read this answer in context 👍 0

All Replies (7)

more options

Was this a upgrade or clean FF install where there was no FF before?

more options

Some problems occur when your Internet security program was set to trust the previous version of Firefox, but no longer recognizes your updated version as trusted. Now how to fix the problem: To allow Firefox to connect to the Internet again;

  • Make sure your Internet security software is up-to-date (i.e. you are running the latest version).
  • Remove Firefox from your program's list of trusted or recognized programs. For detailed instructions, see

Configure firewalls so that Firefox can access the Internet. {web link}

more options

FredMcD said

Some problems occur when your Internet security program was set to trust the previous version of Firefox, but no longer recognizes your updated version as trusted. Now how to fix the problem: To allow Firefox to connect to the Internet again;
  • Make sure your Internet security software is up-to-date (i.e. you are running the latest version).
  • Remove Firefox from your program's list of trusted or recognized programs. For detailed instructions, see
Configure firewalls so that Firefox can access the Internet. {web link}

Hi Fred and thanks for the quick response! I have tried the suggestion in your post, and still no luck. The problem still persists.

WestEnd said

Was this a upgrade or clean FF install where there was no FF before?

At first it was an upgrade, then I followed the directions on how to completely remove the firefox installation and do a "clean" install. However, i'm not entirely sure how clean the installs were despite the fact that firefox did recognize the program being installed previously. Hope this helps give some more information.

Appreciate the help.

more options

fallenone008 said

. . . . firefox did recognize the program being installed previously

Firefox comes in two or more folders on all computers. They are;

Maintenance: (Programs Folder) <Windows Only> Firefox itself: (Programs Folder) And two folders in the profile of each user on the computer for each Firefox profile for that user.

If you remove the Firefox folder, the user profiles would not be affected.

more options

Chosen Solution

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

more options

FredMcD said

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

Putting Firefox into safe mode alone did not fix the problem. When I booted the computer into safe mode with networking, Firefox was working! I then restarted my computer again to normal operating standards, and for some reason Firefox started working!

It kind of baffles me how something like that could fix the issue though. How does simply restarting into safe mode work? In any case, thank you for your help and support. Much appreciated!

more options

Glad to help. Safe Surfing.

Sometimes, Safe Mode removes bad files.