X
Tap here to go to the mobile version of the site.
An updated version of Firefox is available to address the issues with Add-ons disabled or fail to install on Firefox. You can download the update for your OS here: https://www.mozilla.org/firefox/new/ For Known Issues and Workarounds, please check out the update at https://support.mozilla.org/kb/add-ons-disabled-or-fail-to-install-firefox

Support Forum

High RAM usage

Posted

Why Firefox using all of my memory. My PC 8GB RAM. Firefox uses 6GB RAM only for 1 tab? I only read manga at http://www.mangahere.cc/ if the ram is almost full, I have to restart Firefox. Why is RAM management in Firefox so bad? I'm tired of this, please fix it. If you don't believe it, you can test it by reading a random manga.

Why do I restart firefox when ram starts full. Because, if I don't restart, then the other programs that run will lag or hang. In other words, Firefox makes other programs to move to a virtual memory (page file).

I hope I can limit firefox to use RAM (for example 3GB).

Why Firefox using all of my memory. My PC 8GB RAM. Firefox uses 6GB RAM only for 1 tab? I only read manga at http://www.mangahere.cc/ if the ram is almost full, I have to restart Firefox. Why is RAM management in Firefox so bad? I'm tired of this, please fix it. If you don't believe it, you can test it by reading a random manga. Why do I restart firefox when ram starts full. Because, if I don't restart, then the other programs that run will lag or hang. In other words, Firefox makes other programs to move to a virtual memory (page file). I hope I can limit firefox to use RAM (for example 3GB).
Attached screenshots

Additional System Details

Installed Plug-ins

  • Shockwave Flash 31.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0

More Information

FredMcD
  • Top 10 Contributor
4075 solutions 56847 answers

https://support.mozilla.org/kb/Firefox+is+already+running+but+is+not+responding

https://support.mozilla.org/en-US/kb/firefox-slow-how-make-it-faster

https://support.mozilla.org/en-US/kb/firefox-uses-too-many-cpu-resources-how-fix

https://support.mozilla.org/en-US/kb/firefox-uses-too-much-memory-ram

https://support.mozilla.org/en-US/kb/firefox-hangs-or-not-responding


More than one process is normal for the current Firefox. http://www.ghacks.net/2016/07/22/multi-process-firefox/

Multi-process Firefox is codenamed "e10s". https://wiki.mozilla.org/Firefox/multiprocess


Try to disable multi-process tabs in Firefox. You can disable multi-process tabs in Firefox by setting the related prefs to false on the about:config page.

browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false

Type about:config<enter> in the address bar. If a warning screen comes up, press the I Accept the Risk button. At the top of the screen is a search bar.

https://support.mozilla.org/kb/Firefox+is+already+running+but+is+not+responding https://support.mozilla.org/en-US/kb/firefox-slow-how-make-it-faster https://support.mozilla.org/en-US/kb/firefox-uses-too-many-cpu-resources-how-fix https://support.mozilla.org/en-US/kb/firefox-uses-too-much-memory-ram https://support.mozilla.org/en-US/kb/firefox-hangs-or-not-responding --------------------- More than one process is normal for the current Firefox. http://www.ghacks.net/2016/07/22/multi-process-firefox/ Multi-process Firefox is codenamed "e10s". https://wiki.mozilla.org/Firefox/multiprocess Try to disable multi-process tabs in Firefox. You can disable multi-process tabs in Firefox by setting the related prefs to false on the '''about:config''' page. '''browser.tabs.remote.autostart''' = false '''browser.tabs.remote.autostart.2''' = false Type '''about:config'''<enter> in the address bar. If a warning screen comes up, press the '''I Accept the Risk''' button. At the top of the screen is a search bar.

Question owner

FredMcD said

bla bla bla

Don't you understand my question? This is not a process problem, but a RAM management problem. And I've tried everything you said. And that doesn't work.

I am also not a beginner, I have also searched for solutions before writing on the support forum here. Why don't you try visiting http://www.mangahere.cc/ and reading something manga, and open up to hundreds of pages. And look at Firefox's RAM management is very bad.

''FredMcD [[#answer-1163986|said]]'' <blockquote> bla bla bla </blockquote> Don't you understand my question? This is not a process problem, but a RAM management problem. And I've tried everything you said. And that doesn't work. I am also not a beginner, I have also searched for solutions before writing on the support forum here. Why don't you try visiting http://www.mangahere.cc/ and reading something manga, and open up to hundreds of pages. And look at Firefox's RAM management is very bad.
cor-el
  • Top 10 Contributor
  • Moderator
17085 solutions 154305 answers

You can check the about:memory page what is taking up this memory. There are also butons on this page to reduce the memory. You can open "about:" pages via the location/address bar

  • "about:" is a protocol to access special pages

See also this tool that is part of the developer tools.

You can check the <b>about:memory</b> page what is taking up this memory. There are also butons on this page to reduce the memory. You can open "<b>about:</b>" pages via the location/address bar *"about:" is a protocol to access special pages See also this tool that is part of the developer tools. *https://developer.mozilla.org/en/Tools

Question owner

cor-el said

..............

about:memory that doesn't solve the problem. And why should I bother checking about:memory, if I already know what is taking up this memory. And other users also experience this problem: https://support.mozilla.org/en-US/questions/1223605#answer-1153853 Please fix it, don't give me a stupid answer.

''cor-el [[#answer-1164006|said]]'' <blockquote> .............. </blockquote> about:memory that doesn't solve the problem. And why should I bother checking about:memory, if I already know what is taking up this memory. And other users also experience this problem: https://support.mozilla.org/en-US/questions/1223605#answer-1153853 Please fix it, don't give me a stupid answer.
Anabadyo 0 solutions 25 answers

Helpful Reply

Do you use any addons? As I can see you are using Adblock Plus

Do you use any addons? As I can see you are using Adblock Plus
Pj
  • Top 25 Contributor
44 solutions 868 answers

DonKren said

Why Firefox using all of my memory. My PC 8GB RAM. Firefox uses 6GB RAM only for 1 tab? I only read manga at... If the ram is almost full, I have to restart Firefox. Why is RAM management in Firefox so bad?

Have you tried the Performance settings (see image) to see if that would help? I probably have about 1,000 Tabs going across 6 Windows right now. Notice my Memory usage (see image). I do have a Modified Tab setting in About:Config where only one Tab per browser window opens at FF startup (resume sessions). I have one browser window (my main one I'm now using) with over 800 Tabs going. Again, they're not all loaded - only the ones I go back to visit load-up. This helps a lot if one has a great many of Tabs going.

Seeing that you have a problem with very few Tabs open, something is amiss in your setup, be it some other Windows program conflicting (Anti-Virus - temporarily turn off to test) or one or more browser Extensions.

(Edit: I also have a special 0 Disk-Cache/More Memory Cache setup going, but this is a last thing to try item for those interested if all the other methods here on this site don't help enough.)


~Pj (Windows-7, 8GB of Memory, 2010 Desktop System.)

''DonKren [[#question-1237083|said]]'' <blockquote> Why Firefox using all of my memory. My PC 8GB RAM. Firefox uses 6GB RAM only for 1 tab? I only read manga at... *http://www.mangahere.cc/ If the ram is almost full, I have to restart Firefox. Why is RAM management in Firefox so bad? </blockquote> Have you tried the '''Performance''' settings (see image) to see if that would help? I probably have about 1,000 Tabs going across 6 Windows right now. Notice my Memory usage (see image). I do have a Modified Tab setting in '''About:Config''' where only one Tab per browser window opens at FF startup (resume sessions). I have one browser window (my main one I'm now using) with over 800 Tabs going. Again, they're not all loaded - only the ones I go back to visit load-up. This helps a lot if one has a great many of Tabs going. Seeing that you have a problem with very few Tabs open, something is amiss in your setup, be it some other Windows program conflicting (Anti-Virus - temporarily turn off to test) or one or more browser '''Extensions'''. (Edit: I also have a special '''0 Disk-Cache/More Memory Cache''' setup going, but this is a last thing to try item for those interested if all the other methods here on this site don't help enough.) ~Pj (Windows-7, 8GB of Memory, 2010 Desktop System.)

Modified by Pj

Pj
  • Top 25 Contributor
44 solutions 868 answers

Anabadyo said

Do you use any addons? As I can see you are using Adblock Plus

That may it!

See my Update Post:

 *https://support.mozilla.org/en-US/questions/1237697#answer-1166909


~Pj


DonKren said

''Anabadyo [[#answer-1164025|said]]'' <blockquote> Do you use any addons? As I can see you are using Adblock Plus </blockquote> That may it! See my Update Post: *https://support.mozilla.org/en-US/questions/1237697#answer-1166909 ~Pj ''DonKren [[#question-1237083|said]]'' <blockquote> </blockquote>